summaryrefslogtreecommitdiffstats
path: root/keyboards/massdrop/ctrl
Commit message (Collapse)AuthorAgeFilesLines
* Keymap introspection for combos. (#19670)Nick Brassel2023-05-153-3/+0
|
* Fix some missing QMK_KEYBOARD_H includes in user keymaps (#20417)Ryan2023-04-146-317/+268
|
* Move single `LAYOUT`s to data driven (#20365)Ryan2023-04-122-109/+100
|
* Move `RGB_MATRIX_DRIVER` to data driven (#20350)Ryan2023-04-082-1/+3
|
* Make IGNORE_MOD_TAP_INTERRUPT the default behaviour for mod-taps (#20211)precondition2023-04-033-3/+0
|
* Move matrix config to info.json, part 7 (#20020)Ryan2023-03-112-6/+5
|
* VIA Protocol 12 + fixes (#19916)Nick Brassel2023-02-231-1/+1
| | | | | Co-authored-by: Wilba <wilba@wilba.tech> Co-authored-by: zvecr <git@zvecr.com>
* Remove matrix size defines (#19581)Ryan2023-02-171-4/+0
|
* Remove unused `LOCKING_SUPPORT_ENABLE` from config.h (#19748)Ryan2023-02-051-5/+0
|
* Debounce defines cleanup (#19742)Ryan2023-02-031-3/+0
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * Clean up `DEBOUNCE` in config.h, 0-9 * Clean up `DEBOUNCE` in config.h, A * Clean up `DEBOUNCE` in config.h, B * Clean up `DEBOUNCE` in config.h, C * Clean up `DEBOUNCE` in config.h, D * Clean up `DEBOUNCE` in config.h, E * Clean up `DEBOUNCE` in config.h, F * Clean up `DEBOUNCE` in config.h, G * Clean up `DEBOUNCE` in config.h, H * Clean up `DEBOUNCE` in config.h, handwired * Clean up `DEBOUNCE` in config.h, I * Clean up `DEBOUNCE` in config.h, J * Clean up `DEBOUNCE` in config.h, K * Clean up `DEBOUNCE` in config.h, L * Clean up `DEBOUNCE` in config.h, M * Clean up `DEBOUNCE` in config.h, N * Clean up `DEBOUNCE` in config.h, O * Clean up `DEBOUNCE` in config.h, P * Clean up `DEBOUNCE` in config.h, Q * Clean up `DEBOUNCE` in config.h, R * Clean up `DEBOUNCE` in config.h, S * Clean up `DEBOUNCE` in config.h, T * Clean up `DEBOUNCE` in config.h, U * Clean up `DEBOUNCE` in config.h, V * Clean up `DEBOUNCE` in config.h, W * Clean up `DEBOUNCE` in config.h, X * Clean up `DEBOUNCE` in config.h, Y * Clean up `DEBOUNCE` in config.h, Z * Remove default debounce from info.json * Migrate non-default debounce to info.json
* Clean up Force NKRO in config.h (#19718)Ryan2023-01-301-3/+0
|
* Remove usages of config_common.h from config.h files. (#19714)Nick Brassel2023-01-312-2/+0
|
* Remove useless line continuations (#19399)Ryan2022-12-306-103/+103
|
* Tap Dance: remove `qk_` prefix (#19313)Ryan2022-12-143-8/+8
|
* [Core] Replace Tapping Force Hold feature with Quick Tap Term (#17007)Albert Y2022-12-123-3/+3
| | | | | | | | | | | | | | | | | | | | | | | | | * Replace Tapping Force Hold feature with Quick Tap Term * Replace keyboard level TAPPING_FORCE_HOLD with QUICK_TAP_TERM 0 * Deprecate force hold in info_config.json * Before and after quick tap term unit tests * Quick tap unit tests iteration * Keymap config.h correction * Remove TAPPING_FORCE_HOLD_PER_KEY macros that were missed * Add two more test cases for quick tap * Replace TAPPING_FORCE_HOLD with QUICK_TAP_TERM in configs #2 * Replace TAPPING_FORCE_HOLD_PER_KEY with QUICK_TAP_TERM_PER_KEY in configs #2 * Add function declaration for get_quick_tap_term Co-authored-by: Stefan Kerkmann <karlk90@pm.me>
* Change `RGB_MATRIX_STARTUP_*` defines to `RGB_MATRIX_DEFAULT_*` (#19079)Ryan2022-11-275-9/+9
|
* Normalise Space Cadet keycodes (#18864)Ryan2022-10-275-7/+7
|
* Remove legacy Grave Escape keycodes (#18787)Ryan2022-10-201-1/+1
|
* Remove legacy sendstring keycodes (#18749)Ryan2022-10-172-2/+2
|
* Remove legacy keycodes, part 6 (#18740)Ryan2022-10-168-13/+13
| | | | | | | | | * `KC_RSHIFT` -> `KC_RSFT` * `KC_RCTRL` -> `KC_RCTL` * `KC_LSHIFT` -> `KC_LSFT` * `KC_LCTRL` -> `KC_LCTL`
* Remove legacy keycodes, part 5 (#18710)Ryan2022-10-1518-28/+28
| | | | | * `KC_SLCK` -> `KC_SCRL` * `KC_NLCK` -> `KC_NUM`
* Remove RGBLIGHT_ANIMATION and clean up effect defines for L-Q (#18727)Drashna Jaelre2022-10-154-58/+14
|
* Remove legacy keycodes, part 2 (#18660)Ryan2022-10-103-3/+3
| | | | | | | | | | | | | | | | | | | * `KC_SYSREQ` -> `KC_SYRQ` And one `KC_ALT_ERASE` -> `KC_ERAS` * `KC_NONUS_BSLASH` -> `KC_NUBS` * `KC_NUMLOCK` -> `KC_NUM` * `KC_CLCK` -> `KC_CAPS` * `KC_SCROLLLOCK` -> `KC_SCRL` * `KC_LBRACKET` -> `KC_LBRC` * `KC_RBRACKET` -> `KC_RBRC` * `KC_CAPSLOCK` -> `KC_CAPS`
* Fix Per Key LED Indicator Callbacks (#18450)Drashna Jaelre2022-10-047-39/+51
| | | | Co-authored-by: Dasky <32983009+daskygit@users.noreply.github.com> Co-authored-by: Nick Brassel <nick@tzarc.org>
* Remove remaining use of terminal keys and related comment labels (#18402)Johannes Löthberg2022-09-291-1/+1
|
* Change `{LED,RGB}_DISABLE_TIMEOUT` to `{LED,RGB}_MATRIX_TIMEOUT` (#18415)Ryan2022-09-264-4/+0
|
* Change `DRIVER_LED_COUNT` to `{LED,RGB}_MATRIX_LED_COUNT` (#18399)Ryan2022-09-2311-17/+17
|
* Merge remote-tracking branch 'origin/master' into developQMK Bot2022-09-072-1/+23
|\
| * enable RGB matrix effects for drop ctrl (#18291)David Luo2022-09-072-1/+23
| |
* | Use a macro to compute the size of arrays at compile time (#18044)Jeff Epler2022-08-301-2/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * Add ARRAY_SIZE and CEILING utility macros * Apply a coccinelle patch to use ARRAY_SIZE * fix up some straggling items * Fix 'make test:secure' * Enhance ARRAY_SIZE macro to reject acting on pointers The previous definition would not produce a diagnostic for ``` int *p; size_t num_elem = ARRAY_SIZE(p) ``` but the new one will. * explicitly get definition of ARRAY_SIZE * Convert to ARRAY_SIZE when const is involved The following spatch finds additional instances where the array is const and the division is by the size of the type, not the size of the first element: ``` @ rule5a using "empty.iso" @ type T; const T[] E; @@ - (sizeof(E)/sizeof(T)) + ARRAY_SIZE(E) @ rule6a using "empty.iso" @ type T; const T[] E; @@ - sizeof(E)/sizeof(T) + ARRAY_SIZE(E) ``` * New instances of ARRAY_SIZE added since initial spatch run * Use `ARRAY_SIZE` in docs (found by grep) * Manually use ARRAY_SIZE hs_set is expected to be the same size as uint16_t, though it's made of two 8-bit integers * Just like char, sizeof(uint8_t) is guaranteed to be 1 This is at least true on any plausible system where qmk is actually used. Per my understanding it's universally true, assuming that uint8_t exists: https://stackoverflow.com/questions/48655310/can-i-assume-that-sizeofuint8-t-1 * Run qmk-format on core C files touched in this branch Co-authored-by: Stefan Kerkmann <karlk90@pm.me>
* | Switch over MANUFACTURER and PRODUCT to string literals (#18183)Ryan2022-08-282-3/+2
|/
* RESET -> QK_BOOT user keymaps (#17940)Joel Challis2022-08-211-1/+1
|
* Merge remote-tracking branch 'origin/master' into developQMK Bot2022-08-212-4/+5
|\
| * Move keyboard USB IDs and strings to data driven, pass 3 (#18111)Ryan2022-08-212-4/+5
| |
* | Remove `UNUSED_PINS` (#17931)Nick Brassel2022-08-061-1/+0
| |
* | [Core] Process all changed keys in one scan loop, deprecate ↵Stefan Kerkmann2022-08-063-3/+0
| | | | | | | | `QMK_KEYS_PER_SCAN` (#15292)
* | Merge remote-tracking branch 'origin/master' into developQMK Bot2022-07-022-0/+141
|\|
| * Added VIA support for Drop CTRL (#17336)InonL2022-07-022-0/+141
| | | | | | Co-authored-by: Drashna Jaelre <drashna@live.com>
* | Removes terminal from QMK. (#17258)Nick Brassel2022-05-303-3/+0
|/
* Added massdrop/ctrl:xanimos keymap (#16187)Daniel Weeks2022-04-226-0/+982
| | | Co-authored-by: xanimos <dan@xanimos.com>
* Remove `NO_ACTION_MACRO` and `NO_ACTION_FUNCTION` from keyboard config.h ↵Ryan2022-03-151-2/+0
| | | | (#16655)
* Merge remote-tracking branch 'origin/master' into developQMK Bot2022-01-112-0/+157
|\
| * [keymap] Add massdrop/ctrl R167 keymap (#15585)Winston Durand2022-01-102-0/+157
| |
* | Refactor `bootloader_jump()` implementations (#15450)Ryan2021-12-271-0/+3
|/ | | | | | | * Refactor `bootloader_jump()` implementations * Fix tests? * Rename `atmel-samba` to `md-boot`
* Remove unnecessary backslash-escapes in default keymaps (#15472)Ryan2021-12-142-36/+36
| | | | | | | * Remove unnecessary backslash-escapes in default keymaps * Remove unnecessary backslash-escapes in via keymaps * Remove unnecessary backslash-escapes in default-ish keymaps
* Fix up build options comments (#15463)Ryan2021-12-121-1/+1
|
* Tidy up NKRO_ENABLE rules (#15382)Ryan2021-12-091-2/+1
|
* Tidy up `SLEEP_LED_ENABLE` rules (#15362)Ryan2021-12-011-2/+0
|
* Require explicit enabling of RGB Matrix modes (#15018)Drashna Jaelre2021-11-153-74/+122
|
* Merge remote-tracking branch 'origin/master' into developQMK Bot2021-11-057-0/+541
|\