summaryrefslogtreecommitdiffstats
path: root/pkgs/simple
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/simple')
-rw-r--r--pkgs/simple/hidapitester.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/pkgs/simple/hidapitester.nix b/pkgs/simple/hidapitester.nix
new file mode 100644
index 0000000..d30a11a
--- /dev/null
+++ b/pkgs/simple/hidapitester.nix
@@ -0,0 +1,27 @@
+{ pkgs }:
+
+pkgs.stdenv.mkDerivation rec {
+ pname = "hidapitester";
+ version = "0.5";
+
+ src = pkgs.fetchFromGitHub {
+ owner = "todbot";
+ repo = "hidapitester";
+ rev = "tags/${version}";
+ hash = "sha256-QVc1P+FW4B9GZIzAg/BOKGnP7aotNUYdpzrc3/dPs58=";
+ };
+
+ installPhase = ''
+ mkdir -p $out/bin
+ cp hidapitester $out/bin/
+ '';
+
+ nativeBuildInputs = [
+ pkgs.pkg-config
+ ];
+
+ buildInputs = [
+ pkgs.hidapi
+ pkgs.udev
+ ];
+}