summaryrefslogtreecommitdiffstats
path: root/pkgs/simple
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2024-04-11 04:29:15 +0200
committertv <tv@krebsco.de>2024-04-11 04:29:15 +0200
commit71b964a7c095ecf981e74d6bb4557de36142e8da (patch)
tree2238d270e00d3826ea93a60f8a4fb0e1fab3f259 /pkgs/simple
parent97fca3f7718db009a6b3c75792c38d90a413870a (diff)
hidapitester: init at 0.5
Diffstat (limited to 'pkgs/simple')
-rw-r--r--pkgs/simple/hidapitester.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/pkgs/simple/hidapitester.nix b/pkgs/simple/hidapitester.nix
new file mode 100644
index 0000000..d30a11a
--- /dev/null
+++ b/pkgs/simple/hidapitester.nix
@@ -0,0 +1,27 @@
+{ pkgs }:
+
+pkgs.stdenv.mkDerivation rec {
+ pname = "hidapitester";
+ version = "0.5";
+
+ src = pkgs.fetchFromGitHub {
+ owner = "todbot";
+ repo = "hidapitester";
+ rev = "tags/${version}";
+ hash = "sha256-QVc1P+FW4B9GZIzAg/BOKGnP7aotNUYdpzrc3/dPs58=";
+ };
+
+ installPhase = ''
+ mkdir -p $out/bin
+ cp hidapitester $out/bin/
+ '';
+
+ nativeBuildInputs = [
+ pkgs.pkg-config
+ ];
+
+ buildInputs = [
+ pkgs.hidapi
+ pkgs.udev
+ ];
+}