summaryrefslogtreecommitdiffstats
path: root/modules/hosts.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2023-09-11 18:24:28 +0200
committertv <tv@krebsco.de>2023-09-13 18:07:11 +0200
commit0c4f3acb281be6290c55a6e96bc29fab5b5c7a11 (patch)
treedadaec00477a095273475ac345b2066b4748c399 /modules/hosts.nix
parentab1d0479e90f11806d4703ec6fffed3d5f782914 (diff)
stockholm -> hrm
Diffstat (limited to 'modules/hosts.nix')
-rw-r--r--modules/hosts.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/modules/hosts.nix b/modules/hosts.nix
new file mode 100644
index 0000000..ba7ffe3
--- /dev/null
+++ b/modules/hosts.nix
@@ -0,0 +1,8 @@
+{ config, lib, mylib, ... }: {
+ options.tv.hosts = lib.mkOption {
+ type = lib.types.attrsOf mylib.types.host;
+ default =
+ lib.filterAttrs (_: host: host.owner.name == "tv")
+ config.krebs.hosts;
+ };
+}