summaryrefslogtreecommitdiffstats
path: root/modules/hosts.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/hosts.nix')
-rw-r--r--modules/hosts.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/modules/hosts.nix b/modules/hosts.nix
new file mode 100644
index 0000000..ba7ffe3
--- /dev/null
+++ b/modules/hosts.nix
@@ -0,0 +1,8 @@
+{ config, lib, mylib, ... }: {
+ options.tv.hosts = lib.mkOption {
+ type = lib.types.attrsOf mylib.types.host;
+ default =
+ lib.filterAttrs (_: host: host.owner.name == "tv")
+ config.krebs.hosts;
+ };
+}