aboutsummaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2024-11-06 20:34:47 +0100
committertv <tv@krebsco.de>2024-11-06 20:44:37 +0100
commit594dcfb9bc6085c5c328c1a801b27f7352af612f (patch)
tree0a48e44e86b39eaf92d230b8becd916e99fc542c /flake.nix
parent77ec527f311091847b800fee01fd050953a65185 (diff)
configure hanck_duo shield
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix18
1 files changed, 16 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index 7e5dd7c..1e88d01 100644
--- a/flake.nix
+++ b/flake.nix
@@ -6,9 +6,19 @@
url = "github:lilyinstarlight/zmk-nix";
inputs.nixpkgs.follows = "nixpkgs";
};
+
+ zmk-helpers = {
+ url = "github:urob/zmk-helpers";
+ flake = false;
+ };
+
+ hanck = {
+ url = "git+https://cgit.krebsco.de/hanck";
+ flake = false;
+ };
};
- outputs = { self, nixpkgs, zmk-nix }: let
+ outputs = { self, nixpkgs, zmk-nix, zmk-helpers, hanck }: let
forAllSystems = nixpkgs.lib.genAttrs (nixpkgs.lib.attrNames zmk-nix.packages);
in {
packages = forAllSystems (system: rec {
@@ -20,10 +30,14 @@
src = nixpkgs.lib.sourceFilesBySuffices self [ ".board" ".cmake" ".conf" ".defconfig" ".dts" ".dtsi" ".json" ".keymap" ".overlay" ".shield" ".yml" "_defconfig" ];
board = "nice_nano_v2";
- shield = "lily58_%PART%";
+ shield = "hanck_duo_%PART%";
zephyrDepsHash = "sha256-9xdpgu0/A2ZWmJNSlyQ172MGCnkOf/A8WLYp7dvjJ5A=";
+ extraCmakeFlags = [
+ "-DZMK_EXTRA_MODULES=${hanck}/zmk;${zmk-helpers}"
+ ];
+
meta = {
description = "ZMK firmware";
license = nixpkgs.lib.licenses.mit;