summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2024-05-08 21:56:19 +0200
committertv <tv@krebsco.de>2024-05-08 21:56:19 +0200
commitcf7377886a55e36701bd0d5ce7c723aa6d7bd9bd (patch)
treeb8a8bc01688d668b7b03f658e7ef637dd774af6a /shell.nix
initial commitHEADmaster
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..7fc0947
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,21 @@
+{ compiler ? "default"
+, nixpkgs ? import <nixpkgs> {}
+}: let
+
+ inherit (nixpkgs) lib pkgs;
+
+ haskellPackages =
+ if compiler == "default" then
+ pkgs.haskellPackages
+ else
+ pkgs.haskell.packages.${compiler};
+
+ drv = haskellPackages.callPackage (import ./.) {};
+
+in
+
+ lib.overrideDerivation drv.env (oldAttrs: {
+ buildInputs = [
+ pkgs.cabal-install
+ ];
+ })