summaryrefslogtreecommitdiffstats
path: root/tv/source.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/source.nix')
-rw-r--r--tv/source.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/tv/source.nix b/tv/source.nix
index b5e3f7cd7..e5e5e0413 100644
--- a/tv/source.nix
+++ b/tv/source.nix
@@ -6,6 +6,11 @@ with import <stockholm/lib>;
}@host: let
builder = if dummy_secrets then "buildbot" else "tv";
_file = <stockholm> + "/tv/1systems/${name}/source.nix";
+ pkgs = import <nixpkgs> {
+ overlays = map import [
+ <stockholm/krebs/5pkgs>
+ ];
+ };
in
evalSource (toString _file) [
{
@@ -20,6 +25,7 @@ in
tv = "/home/tv/secrets/${name}";
};
stockholm.file = toString <stockholm>;
+ stockholm-version.pipe = "${pkgs.stockholm}/bin/get-version";
}
(mkIf (builder == "tv") {
secrets-common.file = "/home/tv/secrets/common";