summaryrefslogtreecommitdiffstats
path: root/tv/2configs/bash/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/2configs/bash/default.nix')
-rw-r--r--tv/2configs/bash/default.nix10
1 files changed, 8 insertions, 2 deletions
diff --git a/tv/2configs/bash/default.nix b/tv/2configs/bash/default.nix
index 40c0725ed..546b2e7b7 100644
--- a/tv/2configs/bash/default.nix
+++ b/tv/2configs/bash/default.nix
@@ -4,7 +4,7 @@ with import <stockholm/lib>;
{
programs.bash = {
- interactiveShellInit = ''
+ interactiveShellInit = /* sh */ ''
HISTCONTROL='erasedups:ignorespace'
HISTSIZE=65536
HISTFILESIZE=$HISTSIZE
@@ -14,7 +14,7 @@ with import <stockholm/lib>;
shopt -s no_empty_cmd_completion
complete -d cd
'';
- promptInit = ''
+ promptInit = /* sh */ ''
case $UID in
0)
PS1='\[\e[1;31m\]\w\[\e[0m\] '
@@ -32,6 +32,12 @@ with import <stockholm/lib>;
if test -n "$SSH_AGENT_PID"; then
PS1="ssh-agent[$SSH_AGENT_PID] $PS1"
fi
+
+ case ''${XMONAD_SPAWN_WORKSPACE-} in
+ stockholm)
+ cd ~/stockholm
+ ;;
+ esac
'';
};
}