summaryrefslogtreecommitdiffstats
path: root/tv/2configs/AO753.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/2configs/AO753.nix')
-rw-r--r--tv/2configs/AO753.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/tv/2configs/AO753.nix b/tv/2configs/AO753.nix
new file mode 100644
index 000000000..96167ce01
--- /dev/null
+++ b/tv/2configs/AO753.nix
@@ -0,0 +1,39 @@
+{ config, pkgs, ... }:
+
+{
+ imports = [
+ ../2configs/smartd.nix
+ ];
+
+ boot.loader.grub = {
+ device = "/dev/sda";
+ splashImage = null;
+ };
+
+ boot.initrd.availableKernelModules = [
+ "ahci"
+ ];
+
+ boot.kernelModules = [
+ "kvm-intel"
+ "wl"
+ ];
+
+ boot.extraModulePackages = [
+ config.boot.kernelPackages.broadcom_sta
+ ];
+
+ networking.wireless.enable = true;
+
+ services.logind.extraConfig = ''
+ HandleHibernateKey=ignore
+ HandleLidSwitch=ignore
+ HandlePowerKey=ignore
+ HandleSuspendKey=ignore
+ '';
+
+ nixpkgs.config = {
+ allowUnfree = false;
+ allowUnfreePredicate = (x: pkgs.lib.hasPrefix "broadcom-sta-" x.name);
+ };
+}