summaryrefslogtreecommitdiffstats
path: root/shared/2configs/shared-buildbot.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shared/2configs/shared-buildbot.nix')
-rw-r--r--shared/2configs/shared-buildbot.nix49
1 files changed, 20 insertions, 29 deletions
diff --git a/shared/2configs/shared-buildbot.nix b/shared/2configs/shared-buildbot.nix
index 688f8f9aa..58db4c94c 100644
--- a/shared/2configs/shared-buildbot.nix
+++ b/shared/2configs/shared-buildbot.nix
@@ -71,7 +71,11 @@
# prepare grab_repo step for stockholm
grab_repo = steps.Git(repourl=stockholm_repo, mode='incremental')
- env = {"LOGNAME": "shared", "NIX_REMOTE": "daemon"}
+ env = {
+ "LOGNAME": "shared",
+ "NIX_REMOTE": "daemon",
+ "dummy_secrets": "true",
+ }
# prepare nix-shell
# the dependencies which are used by the test script
@@ -91,37 +95,24 @@
'';
builder = {
fast-tests = ''
- f = util.BuildFactory()
- f.addStep(grab_repo)
- for i in [ "test-centos7", "wolf", "test-failing" ]:
- addShell(f,name="populate-{}".format(i),env=env,
- command=nixshell + \
- ["{}(make system={} populate debug=true)".format("!" if "failing" in i else "",i)])
+ f = util.BuildFactory()
+ f.addStep(grab_repo)
- # XXX we must prepare ./retiolum.rsa_key.priv for secrets to work
- addShell(f,name="instantiate-test-all-modules",env=env,
- command=nixshell + \
- ["touch retiolum.rsa_key.priv; \
- nix-instantiate \
- --show-trace --eval --strict --json \
- -I nixos-config=./shared/1systems/test-all-krebs-modules.nix \
- -I secrets=. \
- -A config.system.build.toplevel"]
- )
+ for i in [ "test-minimal-deploy", "test-all-krebs-modules", "wolf", "test-centos7" ]:
+ addShell(f,name="build-{}".format(i),env=env,
+ command=nixshell + \
+ ["mkdir -p /tmp/testbuild/$LOGNAME && touch /tmp/testbuild/$LOGNAME/.populate; \
+ make \
+ test \
+ target=$LOGNAME@${config.krebs.build.host.name}/tmp/testbuild/$LOGNAME \
+ method=eval \
+ system={}".format(i)])
- addShell(f,name="build-test-minimal",env=env,
- command=nixshell + \
- ["nix-instantiate \
- --show-trace --eval --strict --json \
- -I nixos-config=./shared/1systems/test-minimal-deploy.nix \
- -I secrets=. \
- -A config.system.build.toplevel"]
- )
+ bu.append(util.BuilderConfig(name="fast-tests",
+ slavenames=slavenames,
+ factory=f))
- bu.append(util.BuilderConfig(name="fast-tests",
- slavenames=slavenames,
- factory=f))
- '';
+ '';
# this build will try to build against local nixpkgs
# TODO change to do a 'local' populate and use the retrieved nixpkgs
build-local = ''