summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/rtorrent.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/rtorrent.nix')
-rw-r--r--makefu/2configs/rtorrent.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/makefu/2configs/rtorrent.nix b/makefu/2configs/rtorrent.nix
new file mode 100644
index 000000000..9e2990cab
--- /dev/null
+++ b/makefu/2configs/rtorrent.nix
@@ -0,0 +1,19 @@
+_:
+let
+ listenPort = 60123;
+ xml-port = 5000;
+ authfile = <torrent-secrets/authfile>;
+in {
+ makefu.rtorrent = {
+ enable = true;
+ web = {
+ enable = true;
+ enableAuth = true;
+ inherit authfile;
+ };
+ rutorrent.enable = true;
+ enableXMLRPC = true;
+ logLevel = "debug";
+ inherit listenPort;
+ };
+}