summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/home/ham/docker.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/home/ham/docker.nix')
-rw-r--r--makefu/2configs/home/ham/docker.nix30
1 files changed, 0 insertions, 30 deletions
diff --git a/makefu/2configs/home/ham/docker.nix b/makefu/2configs/home/ham/docker.nix
deleted file mode 100644
index e8a47dbbb..000000000
--- a/makefu/2configs/home/ham/docker.nix
+++ /dev/null
@@ -1,30 +0,0 @@
-{ config, pkgs, lib, ... }:
-let
- confdir = "/var/lib/homeassistant-docker";
-in {
- imports = [
- ./nginx.nix
- ./mqtt.nix
- ./signal-rest
- ./signal-rest/service.nix
- ];
-
- networking.firewall.allowedTCPPorts = [ 8123 ];
- state = [ "/var/lib/hass/known_devices.yaml" ];
- virtualisation.oci-containers.containers.hass = {
- image = "homeassistant/home-assistant:latest";
- environment = {
- TZ = "Europe/Berlin";
- UMASK = "007";
- };
- extraOptions = ["--net=host" ];
- volumes = [
- "${confdir}:/config"
- #"/data/music:/config/media"
- ];
- };
- systemd.tmpfiles.rules = [
- #"f ${confdir}/docker-run 0770 kiosk kiosk - -"
- "d ${confdir} 0770 kiosk kiosk - -"
- ];
-}