summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/bureautomation/brother-ql-web.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/bureautomation/brother-ql-web.nix')
-rw-r--r--makefu/2configs/bureautomation/brother-ql-web.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/makefu/2configs/bureautomation/brother-ql-web.nix b/makefu/2configs/bureautomation/brother-ql-web.nix
new file mode 100644
index 000000000..26887db03
--- /dev/null
+++ b/makefu/2configs/bureautomation/brother-ql-web.nix
@@ -0,0 +1,23 @@
+ {pkgs, ... }:
+ let
+ pkg = pkgs.brother_ql_web;
+ in {
+ systemd.services.brother-ql-web = {
+ after = [ "network.target" ];
+ description = "Brother QL Web Interface";
+ wantedBy = [ "multi-user.target" ];
+ environment = {
+ FLASK_PRINTER = "usb://0x04f9:0x209b/000F1Z401759";
+ FLASK_MODEL = "QL-800";
+ #FLASK_SERVER_PORT = "8013";
+ #FLASK_LABEL_DEFAULT_SIZE = "d24";
+ #FLASK_LABEL_DEFAULT_QR_SIZE = "7";
+ };
+ serviceConfig = {
+ ExecStart = "${pkg}/bin/brother_ql_web";
+ DynamicUser = true;
+ SupplementaryGroups = "lp";
+ Restart = "always";
+ };
+ };
+}