summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/snake/disk.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/1systems/snake/disk.nix')
-rw-r--r--makefu/1systems/snake/disk.nix64
1 files changed, 0 insertions, 64 deletions
diff --git a/makefu/1systems/snake/disk.nix b/makefu/1systems/snake/disk.nix
deleted file mode 100644
index f9e14844f..000000000
--- a/makefu/1systems/snake/disk.nix
+++ /dev/null
@@ -1,64 +0,0 @@
-{ disks ? [ "/dev/sda" ], ... }: {
- disk = {
- x = {
- type = "disk";
- device = "/dev/sda";
- content = {
- type = "table";
- format = "gpt";
- partitions = [
- {
- name = "boot";
- type = "partition";
- start = "0";
- end = "1M";
- part-type = "primary";
- flags = ["bios_grub"];
- }
- {
- type = "partition";
- name = "ESP";
- start = "1M";
- end = "512MiB";
- fs-type = "fat32";
- bootable = true;
- content = {
- type = "filesystem";
- format = "vfat";
- mountpoint = "/boot";
- };
- }
- {
- type = "partition";
- name = "zfs";
- start = "512MiB";
- end = "100%";
- content = {
- type = "zfs";
- pool = "zroot";
- };
- }
- ];
- };
- };
- };
- zpool = {
- zroot = {
- type = "zpool";
- rootFsOptions.compression = "lz4";
- mountpoint = "/";
-
- datasets = {
- home = {
- zfs_type = "filesystem";
- mountpoint = "/home";
- options.mountpoint = "legacy";
- };
- reserved = {
- zfs_type = "filesystem";
- options.refreservation = "1G";
- };
- };
- };
- };
-}