summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/minicake/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/1systems/minicake/config.nix')
-rw-r--r--makefu/1systems/minicake/config.nix27
1 files changed, 0 insertions, 27 deletions
diff --git a/makefu/1systems/minicake/config.nix b/makefu/1systems/minicake/config.nix
deleted file mode 100644
index fe66679ad..000000000
--- a/makefu/1systems/minicake/config.nix
+++ /dev/null
@@ -1,27 +0,0 @@
-{ config,nixpkgsPath, pkgs, lib, ... }:
-{
- krebs = {
- enable = true;
-
- dns.providers.lan = "hosts";
- build.user = config.krebs.users.makefu;
- };
- imports = [
- (nixpkgsPath + "/nixos/modules/profiles/minimal.nix")
- (nixpkgsPath + "/nixos/modules/profiles/installation-device.nix")
- ];
-
- # cifs-utils fails to cross-compile
- # Let's simplify this by removing all unneeded filesystems from the image.
- boot.supportedFilesystems = lib.mkForce [ "vfat" ];
-
- boot.kernelPackages = lib.mkDefault pkgs.linuxPackages_latest;
-
-
- users.users = {
- root = {
- openssh.authorizedKeys.keys = [ config.krebs.users.makefu.pubkey ];
- };
- };
- services.openssh.enable = true;
-}