summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/darth.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/1systems/darth.nix')
-rw-r--r--makefu/1systems/darth.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/makefu/1systems/darth.nix b/makefu/1systems/darth.nix
new file mode 100644
index 000000000..a33744f0b
--- /dev/null
+++ b/makefu/1systems/darth.nix
@@ -0,0 +1,17 @@
+{ config, pkgs, lib, ... }:
+
+with config.krebs.lib;
+{
+ imports = [
+ ../2configs/fs/single-partition-ext4.nix
+ ../2configs/zsh-user.nix
+ ../.
+ ];
+
+ krebs.retiolum.enable = true;
+
+ boot.loader.grub.device = "/dev/disk/by-id/ata-ADATA_SSD_S599_64GB_10460000000000000039";
+ users.users.root.openssh.authorizedKeys.keys = [
+ config.krebs.users.makefu-omo.pubkey
+ ];
+}