summaryrefslogtreecommitdiffstats
path: root/lass/1systems/mors.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/1systems/mors.nix')
-rw-r--r--lass/1systems/mors.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/lass/1systems/mors.nix b/lass/1systems/mors.nix
index d3878d305..1aa4d9b23 100644
--- a/lass/1systems/mors.nix
+++ b/lass/1systems/mors.nix
@@ -1,5 +1,6 @@
{ config, pkgs, ... }:
+with config.krebs.lib;
{
imports = [
../.
@@ -66,6 +67,16 @@
'';
};
}
+ {
+ krebs.nginx = {
+ enable = true;
+ servers.default.locations = [
+ (nameValuePair "~ ^/~(.+?)(/.*)?\$" ''
+ alias /home/$1/public_html$2;
+ '')
+ ];
+ };
+ }
];
krebs.build.host = config.krebs.hosts.mors;
@@ -170,6 +181,8 @@
'';
environment.systemPackages = with pkgs; [
+ exfat
+
acronym
cac-api
sshpass
@@ -179,6 +192,8 @@
urban
mk_sql_pair
remmina
+
+ logf
];
#TODO: fix this shit