summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/ssh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/3modules/ssh.nix')
-rw-r--r--krebs/3modules/ssh.nix23
1 files changed, 0 insertions, 23 deletions
diff --git a/krebs/3modules/ssh.nix b/krebs/3modules/ssh.nix
index 58f3a3c10..aba825c29 100644
--- a/krebs/3modules/ssh.nix
+++ b/krebs/3modules/ssh.nix
@@ -4,32 +4,9 @@ let
cfg = config.krebs;
out = {
- options.krebs = api;
config = lib.mkIf cfg.enable imp;
};
- api = {
- zone-head-config = mkOption {
- type = with types; attrsOf str;
- description = ''
- The zone configuration head which is being used to create the
- zone files. The string for each key is pre-pended to the zone file.
- '';
- # TODO: configure the default somewhere else,
- # maybe use krebs.dns.providers
- default = {
-
- # github.io -> 192.30.252.154
- "krebsco.de" = ''
- $TTL 86400
- @ IN SOA dns19.ovh.net. tech.ovh.net. (2015052000 86400 3600 3600000 86400)
- IN NS ns19.ovh.net.
- IN NS dns19.ovh.net.
- '';
- };
- };
- };
-
imp = lib.mkMerge [
{
services.openssh.hostKeys =