summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/shack/gitlab-runner.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/2configs/shack/gitlab-runner.nix')
-rw-r--r--krebs/2configs/shack/gitlab-runner.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/krebs/2configs/shack/gitlab-runner.nix b/krebs/2configs/shack/gitlab-runner.nix
index d525e7987..a27fe29ae 100644
--- a/krebs/2configs/shack/gitlab-runner.nix
+++ b/krebs/2configs/shack/gitlab-runner.nix
@@ -1,4 +1,4 @@
-{ pkgs,lib, ... }:
+{ config, lib, pkgs, ... }:
{
boot.kernel.sysctl."net.ipv4.ip_forward" = true;
services.gitlab-runner = {
@@ -10,7 +10,7 @@
# File should contain at least these two variables:
# `CI_SERVER_URL`
# `REGISTRATION_TOKEN`
- registrationConfigFile = toString <secrets/shackspace-gitlab-ci>;
+ registrationConfigFile = "${config.krebs.secret.directory}/shackspace-gitlab-ci";
dockerImage = "alpine";
dockerVolumes = [
"/nix/store:/nix/store:ro"