summaryrefslogtreecommitdiffstats
path: root/tv/5pkgs/simple/fzmenu/default.nix
diff options
context:
space:
mode:
authorlassulus <git@lassul.us>2023-09-14 12:18:45 +0200
committerlassulus <git@lassul.us>2023-09-14 12:18:45 +0200
commit4820fc27cdc44a12b57d52c5fb7a932407d765a1 (patch)
tree3a31e612fe6141c1079a7fee37db1bb80486ac33 /tv/5pkgs/simple/fzmenu/default.nix
parentd5305cdab1eadfe972ae0d1adc94192bb62ca6bc (diff)
parent1e03553fe6058d06c00a6c92e0ef486282057595 (diff)
Merge remote-tracking branch 'ni/master'
Diffstat (limited to 'tv/5pkgs/simple/fzmenu/default.nix')
-rw-r--r--tv/5pkgs/simple/fzmenu/default.nix50
1 files changed, 0 insertions, 50 deletions
diff --git a/tv/5pkgs/simple/fzmenu/default.nix b/tv/5pkgs/simple/fzmenu/default.nix
deleted file mode 100644
index 1a285ee99..000000000
--- a/tv/5pkgs/simple/fzmenu/default.nix
+++ /dev/null
@@ -1,50 +0,0 @@
-{ lib, pkgs, stdenv }:
-
-let
- terminal = pkgs.writeDashBin "terminal" ''
- # usage: terminal COMMAND [ARGS...]
- exec ${pkgs.alacritty-tv}/bin/alacritty \
- --profile=fzmenu \
- --class AlacrittyFzmenuFloat \
- -e "$@"
- '';
-in
-
-pkgs.runCommand "fzmenu" {
-} /* sh */ ''
- mkdir $out
-
- cp -r ${./bin} $out/bin
-
- substituteInPlace $out/bin/otpmenu \
- --replace '#! /bin/sh' '#! ${pkgs.dash}/bin/dash' \
- --replace '#PATH=' PATH=${lib.makeBinPath [
- pkgs.coreutils
- pkgs.dash
- pkgs.findutils
- pkgs.fzf
- pkgs.gawk
- (pkgs.pass.withExtensions (ext: [
- ext.pass-otp
- ]))
- pkgs.utillinux
- pkgs.xdotool
- terminal
- ]}
-
- substituteInPlace $out/bin/passmenu \
- --replace '#! /bin/sh' '#! ${pkgs.dash}/bin/dash' \
- --replace '#PATH=' PATH=${lib.makeBinPath [
- pkgs.coreutils
- pkgs.dash
- pkgs.findutils
- pkgs.fzf
- pkgs.gawk
- (pkgs.pass.withExtensions (ext: [
- ext.pass-otp
- ]))
- pkgs.utillinux
- pkgs.xdotool
- terminal
- ]}
-''