summaryrefslogtreecommitdiffstats
path: root/tv/2configs/urlwatch.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2019-09-06 15:11:25 +0200
committermakefu <github@syntax-fehler.de>2019-09-06 15:11:25 +0200
commit8901bab8ad2f1db1ac7a1fabec091be3a14a1c20 (patch)
tree1116f0bc3ad2da388a6d066f95a55740baf1865f /tv/2configs/urlwatch.nix
parentfce2c4275caf7df064fb13a4280291a9aefaef1f (diff)
parente388d02623b98bad5db52b29ea1ef1f494fddae8 (diff)
Merge remote-tracking branch 'tv/master'
Diffstat (limited to 'tv/2configs/urlwatch.nix')
-rw-r--r--tv/2configs/urlwatch.nix10
1 files changed, 8 insertions, 2 deletions
diff --git a/tv/2configs/urlwatch.nix b/tv/2configs/urlwatch.nix
index 40dc7d237..378b5d167 100644
--- a/tv/2configs/urlwatch.nix
+++ b/tv/2configs/urlwatch.nix
@@ -1,9 +1,15 @@
with import <stockholm/lib>;
{ config, pkgs, ... }: let
- json = url: {
+ exec = filename: args: url: {
inherit url;
- filter = "system:${pkgs.jq}/bin/jq .";
+ filter = "system:${
+ concatMapStringsSep " " shell.escape ([filename] ++ toList args)
+ }";
};
+ json = json' ["."];
+ json' = exec "${pkgs.jq}/bin/jq";
+ xml = xml' ["--format" "-"];
+ xml' = exec "${pkgs.libxml2}/bin/xmllint";
in {
krebs.urlwatch = {
enable = true;