summaryrefslogtreecommitdiffstats
path: root/tv/2configs/gitrepos.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2020-07-13 11:43:34 +0200
committermakefu <github@syntax-fehler.de>2020-07-13 11:43:34 +0200
commitcf87c49f2cc5fc36f5b011d627df38443fe419f7 (patch)
tree5f6d721b5fee6f29d2155a4d922f1e2b9dda1c9e /tv/2configs/gitrepos.nix
parent48b953d8118c0d4dbe214e4ef6e3d923b356accf (diff)
parent2e26408bfecf27bc70f7b4955c499029bccfa9f4 (diff)
Merge remote-tracking branch 'tv/master'
Diffstat (limited to 'tv/2configs/gitrepos.nix')
-rw-r--r--tv/2configs/gitrepos.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/tv/2configs/gitrepos.nix b/tv/2configs/gitrepos.nix
index 95ab75b3d..59090c8e3 100644
--- a/tv/2configs/gitrepos.nix
+++ b/tv/2configs/gitrepos.nix
@@ -5,6 +5,29 @@ with import <stockholm/lib>;
let {
body = {
+
+ nixpkgs.config.packageOverrides = super: {
+ cgit = pkgs.symlinkJoin {
+ name = "${super.cgit.name}-tv";
+ paths = [
+ (pkgs.runCommand "${super.cgit.name}-tv-overrides" {
+ } /* sh */ ''
+ mkdir -p $out/lib/cgit/filters
+ cd $out/lib/cgit/filters
+ cp \
+ ${super.cgit}/lib/cgit/filters/syntax-highlighting.py \
+ ${super.cgit}/lib/cgit/filters/.syntax-highlighting.py-wrapped \
+ .
+ sed -i "s:${super.cgit}:$out:" syntax-highlighting.py
+ sed -i '
+ s:^\(formatter =\).*:\1 HtmlFormatter(style="algol_nu"):
+ ' .syntax-highlighting.py-wrapped
+ '')
+ super.cgit
+ ];
+ };
+ };
+
krebs.git = {
enable = true;
cgit = {
@@ -22,6 +45,7 @@ let {
];
root-desc = "mostly krebs";
root-title = "repositories at ${config.krebs.build.host.name}";
+ source-filter = "${pkgs.cgit}/lib/cgit/filters/syntax-highlighting.py";
};
};
repos = repos;