summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/home/ham/automation/light_buttons.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2023-07-28 22:24:15 +0200
committermakefu <github@syntax-fehler.de>2023-07-28 22:24:15 +0200
commit060a8f28fa1fc648bdf66afb31a5d1efac868837 (patch)
tree2b354eacc7897365ee45244fe7a51720e0d0333f /makefu/2configs/home/ham/automation/light_buttons.nix
parentcbfcc890e3b76d942b927809bf981a5fa7289e6a (diff)
makefu: move out to own repo, add vacation-note
Diffstat (limited to 'makefu/2configs/home/ham/automation/light_buttons.nix')
-rw-r--r--makefu/2configs/home/ham/automation/light_buttons.nix69
1 files changed, 0 insertions, 69 deletions
diff --git a/makefu/2configs/home/ham/automation/light_buttons.nix b/makefu/2configs/home/ham/automation/light_buttons.nix
deleted file mode 100644
index 460d48bc4..000000000
--- a/makefu/2configs/home/ham/automation/light_buttons.nix
+++ /dev/null
@@ -1,69 +0,0 @@
-
-let
- inherit (import ../lib) btn_cycle_light;
- schlafzimmer_komode = "light.schlafzimmer_komode_osram";
- schlafzimmer_button = "sensor.schlafzimmer_btn2_click";
-in {
- services.home-assistant.config.automation = [
- # (btn_cycle_light "light.arbeitszimmerbeleuchtung" "arbeitszimmer_btn1")
-
- {
- alias = "toggle keller";
- trigger = {
- platform = "state";
- entity_id = "sensor.keller_btn1_click";
- to = "single";
- };
- action = {
- service = "light.toggle";
- #entity_id = lights;
- data = {
- entity_id = "light.keller_osram";
- brightness = 255;
- };
- };
- }
- {
- alias = "low brightness keller with doubleclick";
- trigger = {
- platform = "state";
- entity_id = "sensor.keller_btn1_click";
- to = "double";
- };
- action = {
- service = "light.toggle";
- data = {
- entity_id = "light.keller_osram";
- brightness = 25;
- };
- };
- }
- # (btn_cycle_light "light.wohnzimmerbeleuchtung" "wohnzimmer_btn3")
- {
- alias = "Dim Toggle schlafzimmer komode";
- trigger = {
- platform = "state";
- entity_id = schlafzimmer_button;
- to = "single";
- };
- action = {
- service = "light.toggle";
- entity_id = schlafzimmer_komode;
- brightness = 1;
- };
- }
- {
- alias = "Bright Toggle schlafzimmer komode";
- trigger = {
- platform = "state";
- entity_id = schlafzimmer_button;
- to = "double";
- };
- action = {
- service = "light.toggle";
- entity_id = schlafzimmer_komode;
- brightness = 255;
- };
- }
- ];
-}