summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/repunit/config.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2017-07-16 12:05:35 +0200
committerlassulus <lassulus@lassul.us>2017-07-16 12:05:35 +0200
commitcd7c0971ccc9023f63feb75d4abe514fdc03a079 (patch)
tree704c47afe8cd43a36f36f251cd53b340ec5ec4da /makefu/1systems/repunit/config.nix
parentb91a4c4b0f0958cdc5e7c0d60523326083f275d4 (diff)
parent0e0ad14c373a038e6d347017f5efe172c7409793 (diff)
Merge remote-tracking branch 'gum/master'
Diffstat (limited to 'makefu/1systems/repunit/config.nix')
-rw-r--r--makefu/1systems/repunit/config.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/makefu/1systems/repunit/config.nix b/makefu/1systems/repunit/config.nix
new file mode 100644
index 000000000..996abff08
--- /dev/null
+++ b/makefu/1systems/repunit/config.nix
@@ -0,0 +1,40 @@
+# Edit this configuration file to define what should be installed on
+# your system. Help is available in the configuration.nix(5) man page
+# and in the NixOS manual (accessible by running ‘nixos-help’).
+
+{ config, pkgs, ... }:
+
+{
+ imports =
+ [ # Include the results of the hardware scan.
+ <stockholm/makefu>
+ <nixpkgs/nixos/modules/profiles/qemu-guest.nix>
+ <stockholm/makefu/2configs/git/cgit-retiolum.nix>
+ <stockholm/makefu/2configs/tinc/retiolum.nix>
+ ];
+ krebs.build.host = config.krebs.hosts.repunit;
+
+ boot.loader.grub.enable = true;
+ boot.loader.grub.version = 2;
+ boot.loader.grub.device = "/dev/vda";
+
+ boot.initrd.availableKernelModules = [ "ata_piix" "uhci_hcd" "ehci_pci" "virtio_pci" "virtio_blk" ];
+ boot.kernelModules = [ ];
+ boot.extraModulePackages = [ ];
+ hardware.enableAllFirmware = true;
+ hardware.cpu.amd.updateMicrocode = true;
+
+# networking.firewall is enabled by default
+ networking.firewall.allowedTCPPorts = [ 80 ];
+ networking.firewall.allowPing = true;
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-label/nixos";
+ fsType = "ext4";
+ };
+
+# $ nix-env -qaP | grep wget
+ environment.systemPackages = with pkgs; [
+ jq
+ ];
+}