summaryrefslogtreecommitdiffstats
path: root/lass/1systems/lasspi/physical.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2021-09-28 22:48:17 +0200
committertv <tv@krebsco.de>2021-09-28 22:48:17 +0200
commited2c6bd9792afbc433ae4eb23f40e17b90420f99 (patch)
tree289de32dd7f58f46accf7ad25ed184db5aa45198 /lass/1systems/lasspi/physical.nix
parent20e358043546482acfa8c6134f095c1a64ef144d (diff)
parente151cfd3298120ec541987d4beb155e18335a0d8 (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to 'lass/1systems/lasspi/physical.nix')
-rw-r--r--lass/1systems/lasspi/physical.nix43
1 files changed, 43 insertions, 0 deletions
diff --git a/lass/1systems/lasspi/physical.nix b/lass/1systems/lasspi/physical.nix
new file mode 100644
index 000000000..80c459a95
--- /dev/null
+++ b/lass/1systems/lasspi/physical.nix
@@ -0,0 +1,43 @@
+{ config, lib, pkgs, ... }:
+{
+ # This configuration worked on 09-03-2021 nixos-unstable @ commit 102eb68ceec
+ # The image used https://hydra.nixos.org/build/134720986
+ imports = [
+ ./config.nix
+ ];
+
+ boot = {
+ # kernelPackages = pkgs.linuxPackages_rpi4;
+ tmpOnTmpfs = true;
+ initrd.availableKernelModules = [ "usbhid" "usb_storage" ];
+ # ttyAMA0 is the serial console broken out to the GPIO
+ kernelParams = [
+ "8250.nr_uarts=1"
+ "console=ttyAMA0,115200"
+ "console=tty1"
+ # Some gui programs need this
+ "cma=128M"
+ ];
+ };
+
+ boot.loader.raspberryPi = {
+ enable = true;
+ version = 4;
+ };
+ boot.loader.grub.enable = false;
+ boot.loader.generic-extlinux-compatible.enable = true;
+
+ # Required for the Wireless firmware
+ hardware.enableRedistributableFirmware = true;
+
+ # Assuming this is installed on top of the disk image.
+ fileSystems = {
+ "/" = {
+ device = "/dev/disk/by-label/NIXOS_SD";
+ fsType = "ext4";
+ options = [ "noatime" ];
+ };
+ };
+
+ powerManagement.cpuFreqGovernor = "ondemand";
+}