summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/simple/whatsupnix/default.nix
diff options
context:
space:
mode:
authorlassulus <lass@lassul.us>2017-05-29 10:54:07 +0200
committerlassulus <lass@lassul.us>2017-05-29 10:54:07 +0200
commit35bc9f03a9bea7c6f864b95c95f5c095fa53e92b (patch)
tree059b5dc3b4fee6838b35f272a75dde3bd2ac785b /krebs/5pkgs/simple/whatsupnix/default.nix
parent6e93f661e0b31c95f69d1bd3a6f208d26e3e0958 (diff)
parent4d1de57df5800879e7fcfcc38e5a10f0c1b993d7 (diff)
Merge remote-tracking branch 'ni/master'
Diffstat (limited to 'krebs/5pkgs/simple/whatsupnix/default.nix')
-rw-r--r--krebs/5pkgs/simple/whatsupnix/default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/krebs/5pkgs/simple/whatsupnix/default.nix b/krebs/5pkgs/simple/whatsupnix/default.nix
new file mode 100644
index 000000000..1a108c5e9
--- /dev/null
+++ b/krebs/5pkgs/simple/whatsupnix/default.nix
@@ -0,0 +1,15 @@
+{ bash, coreutils, gawk, nix, makeWrapper, stdenv }:
+
+stdenv.mkDerivation {
+ name = "whatsupnix";
+ phases = [ "installPhase" ];
+ nativeBuildInputs = [ makeWrapper ];
+ installPhase = ''
+ mkdir -p $out/bin
+ cat - ${./whatsupnix.bash} > $out/bin/whatsupnix <<\EOF
+ #! ${bash}/bin/bash
+ export PATH=${stdenv.lib.makeBinPath [ coreutils gawk nix ]}
+ EOF
+ chmod +x $out/bin/whatsupnix
+ '';
+}