summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/zones.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2023-09-09 19:42:08 +0200
committermakefu <github@syntax-fehler.de>2023-09-09 19:42:08 +0200
commit29d72c898d674d2c18fc0f4a76b5e623de0c3dfe (patch)
treefc4b0695c986a1cda6f1fbbbcbe716e203c54fa3 /krebs/3modules/zones.nix
parente157ffa72856e4378aa23b096b2efff233f3cb3d (diff)
parent083229d0211096daec08673f743ccc45b1d8a0ac (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'krebs/3modules/zones.nix')
-rw-r--r--krebs/3modules/zones.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/krebs/3modules/zones.nix b/krebs/3modules/zones.nix
index 7771d3b51..e68482d77 100644
--- a/krebs/3modules/zones.nix
+++ b/krebs/3modules/zones.nix
@@ -1,6 +1,25 @@
{ config, pkgs, lib, ... }:
with lib; {
+ options.krebs.zone-head-config = mkOption {
+ type = lib.types.attrsOf lib.types.str;
+ description = ''
+ The zone configuration head which is being used to create the
+ zone files. The string for each key is pre-pended to the zone file.
+ '';
+ default = {
+ "krebsco.de" = /* bindzone */ ''
+ $TTL 60
+ @ 3600 IN SOA spam.krebsco.de. spam.krebsco.de. 0 7200 3600 86400 3600
+ @ 3600 IN NS ns1
+ @ 3600 IN NS ni
+ @ 3600 IN NS ns2.he.net.
+ @ 3600 IN NS ns3.he.net.
+ @ 3600 IN NS ns2.hosting.de.
+ '';
+ };
+ };
+
config = {
environment.etc =
mapAttrs'