summaryrefslogtreecommitdiffstats
path: root/keyboards/ploopyco
Commit message (Collapse)AuthorAgeFilesLines
* Move RGBLight animations to data driven (#21635)Ryan2023-08-234-10/+12
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * Move RGBLight animations to data driven, 0-9 * Move RGBLight animations to data driven, A * Move RGBLight animations to data driven, B * Move RGBLight animations to data driven, C * Move RGBLight animations to data driven, D * Move RGBLight animations to data driven, E * Move RGBLight animations to data driven, F * Move RGBLight animations to data driven, G * Move RGBLight animations to data driven, H * Move RGBLight animations to data driven, handwired * Move RGBLight animations to data driven, I * Move RGBLight animations to data driven, J * Move RGBLight animations to data driven, K * Move RGBLight animations to data driven, L * Move RGBLight animations to data driven, M * Move RGBLight animations to data driven, N * Move RGBLight animations to data driven, O * Move RGBLight animations to data driven, P * Move RGBLight animations to data driven, Q * Move RGBLight animations to data driven, R * Move RGBLight animations to data driven, S * Move RGBLight animations to data driven, T * Move RGBLight animations to data driven, U * Move RGBLight animations to data driven, V * Move RGBLight animations to data driven, W * Move RGBLight animations to data driven, X * Move RGBLight animations to data driven, Y * Move RGBLight animations to data driven, Z * Fix incorrect placement * Fix build failures and mismatches
* Move `RGBLED_NUM` to data driven (#21278)Ryan2023-06-184-2/+2
|
* Move `RGBLIGHT_LIMIT_VAL` to data driven (#20974)Ryan2023-05-274-2/+6
| | | | Co-authored-by: Nick Brassel <nick@tzarc.org>
* More `info.json` whitespace cleanups (#20665)Ryan2023-05-035-25/+25
|
* `info.json` whitespace cleanups (#20651)Ryan2023-05-022-7/+9
|
* Move `USB_MAX_POWER_CONSUMPTION` to data driven (#20648)Ryan2023-05-018-12/+8
|
* Encodermap direction define. (#20454)Nick Brassel2023-04-151-1/+1
|
* Migrate `rgblight.pin` and `RGB_DI_PIN` to `ws2812.pin` (#20303)Ryan2023-04-065-5/+9
|
* Clean up usage of `QMK_KEYBOARD_H` (#20167)Ryan2023-03-201-1/+1
|
* Remove useless "ifdef KEYBOARD_*" (#20078)Ryan2023-03-168-137/+0
| | | | Co-authored-by: Nick Brassel <nick@tzarc.org>
* Merge remote-tracking branch 'origin/master' into developQMK Bot2023-02-282-9/+15
|\
| * [Keyboard] remove non-existent method from ploopy documentation (#19957)Shawn Meier2023-02-281-9/+6
| |
| * [Keymap] Drashna updates for 0.20.0 (#19960)Drashna Jaelre2023-02-281-0/+9
| |
* | Remove `"w":1` and `"h":1` from info.json (#19961)Ryan2023-02-281-4/+4
|/
* Reallocate SAFE_RANGE (#19909)Joel Challis2023-02-2313-20/+2
|
* VIA Protocol 12 + fixes (#19916)Nick Brassel2023-02-234-36/+4
| | | | | Co-authored-by: Wilba <wilba@wilba.tech> Co-authored-by: zvecr <git@zvecr.com>
* Move layouts for direct_pins boards to data driven (#19872)Ryan2023-02-198-30/+19
|
* Remove matrix size defines (#19581)Ryan2023-02-173-15/+0
|
* Move Bootmagic config to data driven (#19860)Ryan2023-02-176-12/+9
|
* Migrate `DIRECT_PINS` to data driven (#19826)Ryan2023-02-1412-94/+38
|
* Migrate `MCU` and `BOOTLOADER` to data-driven (#19529)Ryan2023-02-0811-25/+14
|
* Debounce defines cleanup (#19742)Ryan2023-02-036-15/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * Clean up `DEBOUNCE` in config.h, 0-9 * Clean up `DEBOUNCE` in config.h, A * Clean up `DEBOUNCE` in config.h, B * Clean up `DEBOUNCE` in config.h, C * Clean up `DEBOUNCE` in config.h, D * Clean up `DEBOUNCE` in config.h, E * Clean up `DEBOUNCE` in config.h, F * Clean up `DEBOUNCE` in config.h, G * Clean up `DEBOUNCE` in config.h, H * Clean up `DEBOUNCE` in config.h, handwired * Clean up `DEBOUNCE` in config.h, I * Clean up `DEBOUNCE` in config.h, J * Clean up `DEBOUNCE` in config.h, K * Clean up `DEBOUNCE` in config.h, L * Clean up `DEBOUNCE` in config.h, M * Clean up `DEBOUNCE` in config.h, N * Clean up `DEBOUNCE` in config.h, O * Clean up `DEBOUNCE` in config.h, P * Clean up `DEBOUNCE` in config.h, Q * Clean up `DEBOUNCE` in config.h, R * Clean up `DEBOUNCE` in config.h, S * Clean up `DEBOUNCE` in config.h, T * Clean up `DEBOUNCE` in config.h, U * Clean up `DEBOUNCE` in config.h, V * Clean up `DEBOUNCE` in config.h, W * Clean up `DEBOUNCE` in config.h, X * Clean up `DEBOUNCE` in config.h, Y * Clean up `DEBOUNCE` in config.h, Z * Remove default debounce from info.json * Migrate non-default debounce to info.json
* Remove unused `MATRIX_HAS_GHOST` from config.h (#19726)Ryan2023-02-034-13/+0
|
* Remove usages of config_common.h from config.h files. (#19714)Nick Brassel2023-01-315-5/+0
|
* Partially revert #18940 for Ploopy Thumb Trackball (#18943)Drashna Jaelre2023-01-012-0/+37
|
* ploopyco/trackball_mini: always update encoder (#18561)alaviss2022-12-301-8/+9
|
* Remove .noci functionality (#19122)Joel Challis2022-11-211-0/+0
|
* Fix references to `mouse_report_t` (which doesnt exist) (#19107)Pablo Martínez2022-11-184-4/+4
|
* Remove more `UNUSED_PINS` defines (#18940)Ryan2022-11-032-37/+0
|
* Enabling Pointing Device support in register code functions (#18363)Drashna Jaelre2022-09-263-37/+0
|
* Merge remote-tracking branch 'origin/master' into developQMK Bot2022-09-2619-0/+615
|\
| * [Keyboard] Ploopy Thumb Trackball (#18214)Drashna Jaelre2022-09-2519-0/+615
| | | | | | | | | | | | Co-authored-by: Drashna Jaelre <drashna@live.com> Co-authored-by: Ryan <fauxpark@gmail.com> Co-authored-by: Nick Brassel <nick@tzarc.org> Co-authored-by: ploopyco <git@ploopy.co>
* | Use a macro to compute the size of arrays at compile time (#18044)Jeff Epler2022-08-304-8/+8
|/ | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * Add ARRAY_SIZE and CEILING utility macros * Apply a coccinelle patch to use ARRAY_SIZE * fix up some straggling items * Fix 'make test:secure' * Enhance ARRAY_SIZE macro to reject acting on pointers The previous definition would not produce a diagnostic for ``` int *p; size_t num_elem = ARRAY_SIZE(p) ``` but the new one will. * explicitly get definition of ARRAY_SIZE * Convert to ARRAY_SIZE when const is involved The following spatch finds additional instances where the array is const and the division is by the size of the type, not the size of the first element: ``` @ rule5a using "empty.iso" @ type T; const T[] E; @@ - (sizeof(E)/sizeof(T)) + ARRAY_SIZE(E) @ rule6a using "empty.iso" @ type T; const T[] E; @@ - sizeof(E)/sizeof(T) + ARRAY_SIZE(E) ``` * New instances of ARRAY_SIZE added since initial spatch run * Use `ARRAY_SIZE` in docs (found by grep) * Manually use ARRAY_SIZE hs_set is expected to be the same size as uint16_t, though it's made of two 8-bit integers * Just like char, sizeof(uint8_t) is guaranteed to be 1 This is at least true on any plausible system where qmk is actually used. Per my understanding it's universally true, assuming that uint8_t exists: https://stackoverflow.com/questions/48655310/can-i-assume-that-sizeofuint8-t-1 * Run qmk-format on core C files touched in this branch Co-authored-by: Stefan Kerkmann <karlk90@pm.me>
* [Keymap] Drashna keymap updates for 0.18.0 (#18184)Drashna Jaelre2022-08-282-9/+13
| | | Co-authored-by: Ryan <fauxpark@gmail.com>
* RESET -> QK_BOOT user keymaps (#17940)Joel Challis2022-08-212-2/+2
|
* Merge remote-tracking branch 'origin/master' into developQMK Bot2022-08-136-43/+165
|\
| * RFC: add a simple implementation of the ploopy optical encoder (#17912)alaviss2022-08-136-43/+165
| |
* | Remove `UNUSED_PINS` (#17931)Nick Brassel2022-08-0610-14/+14
| |
* | Merge remote-tracking branch 'origin/master' into developQMK Bot2022-08-038-32/+28
|\|
| * Move keyboard USB IDs and strings to data driven: P (#17875)Ryan2022-08-038-32/+28
| |
* | Merge remote-tracking branch 'origin/master' into developQMK Bot2022-07-221-0/+4
|\|
| * Fix compilation error in Ploopy Nano maddie keymap (#17733)Aidan Gauland2022-07-221-0/+4
| |
* | [Core] PMW33XX drivers overhaul (#17613)Stefan Kerkmann2022-07-142-4/+4
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * PMW33XX drivers overhaul This combines the PMW3389 and PM3360 drivers as they only differ in the firmware blobs and CPI get and set functions. The following changes have been made: * PMW3389 now gets the same multi-sensor feature that is already available on the PMW3360. * Introduced a shared pmw33xx_report_t struct is now directly readable via SPI transactions instead of individual byte-sized reads, saving multiple copies and bitshift operations. * pmw33(89/60)_get_report functions had unreachable branches in their motion detection logic these have been simplied as much as possible. * The fast firmware upload option has been removed as this becomes obsolete by the newly introduced polled waiting functions for ChibiOS polled waiting * PMW33(60/89)_SPI_LSBFIRST and PMW33(60/89)_SPI_MODE config options have been removed as they don't need to be configurable. * All PMW3389 and PMW3360 defines have been unified to a PMW33XX prefix to reduce code duplication and make the defines interchangeable * Adjust keyboards to PMW33XX naming scheme
* | Merge remote-tracking branch 'origin/master' into developQMK Bot2022-07-021-0/+5
|\|
| * Added PLOOPY_DRAGSCROLL_H_INVERT (#17453)br2022-07-031-0/+5
| |
* | Merge remote-tracking branch 'origin/master' into developQMK Bot2022-07-025-0/+180
|\|
| * Add lkbm keymap (#17218)Aidan Gauland2022-07-025-0/+180
| |
* | Add support for large Mouse Reports (#16371)Drashna Jaelre2022-06-081-1/+1
|/ | | | Co-authored-by: Sergey Vlasov <sigprof@gmail.com> Co-authored-by: Ryan <fauxpark@gmail.com>
* [Keymap] Fix maddie layout for ploopy/trackball_nano (#17213)Aidan Gauland2022-06-021-27/+28
|
* [Keymap] Drashna update for post Q2 merge (#17241)Drashna Jaelre2022-05-302-1/+3
|