summaryrefslogtreecommitdiffstats
path: root/keyboards/splitkb/aurora/sweep/rev1
diff options
context:
space:
mode:
authorleah-splitkb <103112489+leah-splitkb@users.noreply.github.com>2022-10-13 05:06:18 +0200
committerGitHub <noreply@github.com>2022-10-13 14:06:18 +1100
commita8df5fd3031e97a43c1577e31af6c066bf66b712 (patch)
tree3b05db2c5b6a7beec045deabe4dc3388c4c30bf7 /keyboards/splitkb/aurora/sweep/rev1
parenta195f78200a40f2065b0bf75271fabbb7d381385 (diff)
[Keyboard] Add splitkb.com's Aurora Sweep (#18691)
Diffstat (limited to 'keyboards/splitkb/aurora/sweep/rev1')
-rw-r--r--keyboards/splitkb/aurora/sweep/rev1/config.h45
-rw-r--r--keyboards/splitkb/aurora/sweep/rev1/info.json155
-rw-r--r--keyboards/splitkb/aurora/sweep/rev1/rev1.c33
-rw-r--r--keyboards/splitkb/aurora/sweep/rev1/rules.mk17
4 files changed, 250 insertions, 0 deletions
diff --git a/keyboards/splitkb/aurora/sweep/rev1/config.h b/keyboards/splitkb/aurora/sweep/rev1/config.h
new file mode 100644
index 0000000000..e7b603b575
--- /dev/null
+++ b/keyboards/splitkb/aurora/sweep/rev1/config.h
@@ -0,0 +1,45 @@
+/* Copyright 2022 splitkb.com <support@splitkb.com>
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#pragma once
+
+// `SPLIT_HAND_PIN` can currently be defined in `info.json`,
+// but can't yet be given a value
+#define SPLIT_HAND_PIN F4
+
+// Not yet available in `info.json`
+#ifdef OLED_ENABLE
+# define OLED_DISPLAY_128X32
+# define SPLIT_OLED_ENABLE
+#endif
+
+// Not yet available in `info.json`
+#ifdef RGB_MATRIX_ENABLE
+# define RGB_MATRIX_MAXIMUM_BRIGHTNESS RGBLIGHT_LIMIT_VAL
+# define DRIVER_LED_TOTAL RGBLED_NUM
+# define RGB_MATRIX_SPLIT RGBLED_SPLIT
+# define SPLIT_TRANSPORT_MIRROR
+#endif
+
+// Not yet available in `info.json`
+#ifdef BOOTMAGIC_ENABLE
+ // Top left key on left half
+# define BOOTMAGIC_LITE_ROW 0
+# define BOOTMAGIC_LITE_COLUMN 4
+ // Top right key on right half
+# define BOOTMAGIC_LITE_ROW_RIGHT 4
+# define BOOTMAGIC_LITE_COLUMN_RIGHT 4
+#endif
diff --git a/keyboards/splitkb/aurora/sweep/rev1/info.json b/keyboards/splitkb/aurora/sweep/rev1/info.json
new file mode 100644
index 0000000000..16c490ad5f
--- /dev/null
+++ b/keyboards/splitkb/aurora/sweep/rev1/info.json
@@ -0,0 +1,155 @@
+{
+ "keyboard_name": "Aurora Sweep rev1",
+ "usb": {
+ "pid": "0xEC17"
+ },
+ "features": {
+ "mousekey": true,
+ "bootmagic": true,
+ "extrakey": true
+ },
+ "layouts": {
+ "LAYOUT_split_3x5_2": {
+ "layout": [
+ // Note: `label` is here only for readability,
+ // order must match the parent's definition!
+ {"label": "L01", "matrix": [0, 4]},
+ {"label": "L02", "matrix": [0, 3]},
+ {"label": "L03", "matrix": [0, 2]},
+ {"label": "L04", "matrix": [0, 1]},
+ {"label": "L05", "matrix": [0, 0]},
+ {"label": "R05", "matrix": [4, 0]},
+ {"label": "R04", "matrix": [4, 1]},
+ {"label": "R03", "matrix": [4, 2]},
+ {"label": "R02", "matrix": [4, 3]},
+ {"label": "R01", "matrix": [4, 4]},
+
+ {"label": "L06", "matrix": [1, 4]},
+ {"label": "L07", "matrix": [1, 3]},
+ {"label": "L08", "matrix": [1, 2]},
+ {"label": "L09", "matrix": [1, 1]},
+ {"label": "L10", "matrix": [1, 0]},
+ {"label": "R10", "matrix": [5, 0]},
+ {"label": "R09", "matrix": [5, 1]},
+ {"label": "R08", "matrix": [5, 2]},
+ {"label": "R07", "matrix": [5, 3]},
+ {"label": "R06", "matrix": [5, 4]},
+
+ {"label": "L11", "matrix": [2, 4]},
+ {"label": "L12", "matrix": [2, 3]},
+ {"label": "L13", "matrix": [2, 2]},
+ {"label": "L14", "matrix": [2, 1]},
+ {"label": "L15", "matrix": [2, 0]},
+ {"label": "R15", "matrix": [6, 0]},
+ {"label": "R14", "matrix": [6, 1]},
+ {"label": "R13", "matrix": [6, 2]},
+ {"label": "R12", "matrix": [6, 3]},
+ {"label": "R11", "matrix": [6, 4]},
+
+ {"label": "L16", "matrix": [3, 1]},
+ {"label": "L17", "matrix": [3, 0]},
+ {"label": "R17", "matrix": [7, 0]},
+ {"label": "R16", "matrix": [7, 1]}
+ ]
+ }
+ },
+ "diode_direction": "ROW2COL",
+ "matrix_pins": {
+ "rows": ["F6", "F5", "F7", "B1"],
+ "cols": ["B6", "D4", "C6", "D7", "E6"]
+ },
+ "encoder": {
+ "rotary": [
+ {
+ "pin_a": "B5",
+ "pin_b": "B4"
+ },
+ {
+ "pin_a": "B3",
+ "pin_b": "B2"
+ }
+ ]
+ },
+ "split": {
+ "soft_serial_pin": "D2",
+ "main": "pin",
+ "matrix_pins": {
+ "right": {
+ "rows": ["B1", "F7", "F6", "B3"],
+ "cols": ["B5", "B4", "E6", "D7", "C6"]
+ }
+ },
+ "encoder": {
+ "right": {
+ "rotary": [
+ {
+ "pin_a": "B2",
+ "pin_b": "B6"
+ },
+ {
+ "pin_a": "F5",
+ "pin_b": "D4"
+ }
+ ]
+ }
+ }
+ },
+ "rgblight": {
+ "pin": "D3",
+ "led_count": 46,
+ "split": true,
+ "split_count": [23, 23],
+ "max_brightness": 128
+ },
+ "rgb_matrix": {
+ "driver": "WS2812",
+ "layout": [
+ {"flags": 2, "x": 71, "y": 15}, // L RGB1
+ {"flags": 2, "x": 51, "y": 8}, // L RGB2
+ {"flags": 2, "x": 10, "y": 13}, // L RGB3
+ {"flags": 2, "x": 10, "y": 42}, // L RGB4
+ {"flags": 2, "x": 41, "y": 45}, // L RGB5
+ {"flags": 2, "x": 76, "y": 50}, // L RGB6
+ {"flags": 4, "matrix": [0, 4], "x": 0, "y": 15}, // L SW01
+ {"flags": 4, "matrix": [0, 3], "x": 20, "y": 5}, // L SW02
+ {"flags": 4, "matrix": [0, 2], "x": 41, "y": 0}, // L SW03
+ {"flags": 4, "matrix": [0, 1], "x": 61, "y": 4}, // L SW04
+ {"flags": 4, "matrix": [0, 0], "x": 81, "y": 7}, // L SW05
+ {"flags": 4, "matrix": [1, 4], "x": 0, "y": 31}, // L SW06
+ {"flags": 4, "matrix": [1, 3], "x": 20, "y": 21}, // L SW07
+ {"flags": 4, "matrix": [1, 2], "x": 41, "y": 16}, // L SW08
+ {"flags": 4, "matrix": [1, 1], "x": 61, "y": 20}, // L SW09
+ {"flags": 4, "matrix": [1, 0], "x": 81, "y": 23}, // L SW10
+ {"flags": 4, "matrix": [2, 4], "x": 0, "y": 47}, // L SW11
+ {"flags": 4, "matrix": [2, 3], "x": 20, "y": 37}, // L SW12
+ {"flags": 4, "matrix": [2, 2], "x": 41, "y": 32}, // L SW13
+ {"flags": 4, "matrix": [2, 1], "x": 61, "y": 36}, // L SW14
+ {"flags": 4, "matrix": [2, 0], "x": 81, "y": 39}, // L SW15
+ {"flags": 4, "matrix": [3, 1], "x": 71, "y": 60}, // L SW16
+ {"flags": 4, "matrix": [3, 0], "x": 92, "y": 64}, // L SW17
+ {"flags": 2, "x": 150, "y": 15}, // R RGB1
+ {"flags": 2, "x": 190, "y": 8}, // R RGB2
+ {"flags": 2, "x": 210, "y": 13}, // R RGB3
+ {"flags": 2, "x": 220, "y": 42}, // R RGB4
+ {"flags": 2, "x": 183, "y": 45}, // R RGB5
+ {"flags": 2, "x": 155, "y": 50}, // R RGB6
+ {"flags": 4, "matrix": [4, 0], "x": 143, "y": 7}, // R SW05
+ {"flags": 4, "matrix": [4, 1], "x": 163, "y": 4}, // R SW04
+ {"flags": 4, "matrix": [4, 2], "x": 183, "y": 0}, // R SW03
+ {"flags": 4, "matrix": [4, 3], "x": 204, "y": 5}, // R SW02
+ {"flags": 4, "matrix": [4, 4], "x": 224, "y": 15}, // R SW01
+ {"flags": 4, "matrix": [5, 0], "x": 143, "y": 23}, // R SW10
+ {"flags": 4, "matrix": [5, 1], "x": 163, "y": 20}, // R SW09
+ {"flags": 4, "matrix": [5, 2], "x": 183, "y": 16}, // R SW08
+ {"flags": 4, "matrix": [5, 3], "x": 204, "y": 21}, // R SW07
+ {"flags": 4, "matrix": [5, 4], "x": 224, "y": 31}, // R SW06
+ {"flags": 4, "matrix": [6, 0], "x": 143, "y": 39}, // R SW15
+ {"flags": 4, "matrix": [6, 1], "x": 163, "y": 36}, // R SW14
+ {"flags": 4, "matrix": [6, 2], "x": 183, "y": 32}, // R SW13
+ {"flags": 4, "matrix": [6, 3], "x": 204, "y": 37}, // R SW12
+ {"flags": 4, "matrix": [6, 4], "x": 224, "y": 47}, // R SW11
+ {"flags": 4, "matrix": [7, 0], "x": 132, "y": 64}, // R SW17
+ {"flags": 4, "matrix": [7, 1], "x": 153, "y": 60} // R SW16
+ ]
+ }
+}
diff --git a/keyboards/splitkb/aurora/sweep/rev1/rev1.c b/keyboards/splitkb/aurora/sweep/rev1/rev1.c
new file mode 100644
index 0000000000..ce19aea5ce
--- /dev/null
+++ b/keyboards/splitkb/aurora/sweep/rev1/rev1.c
@@ -0,0 +1,33 @@
+/* Copyright 2022 splitkb.com <support@splitkb.com>
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#ifdef SWAP_HANDS_ENABLE
+// clang-format off
+ __attribute__ ((weak)) const keypos_t PROGMEM hand_swap_config[MATRIX_ROWS][MATRIX_COLS] = {
+ {{0, 4}, {1, 4}, {2, 4}, {3, 4}, {4, 4}},
+ {{0, 5}, {1, 5}, {2, 5}, {3, 5}, {4, 5}},
+ {{0, 6}, {1, 6}, {2, 6}, {3, 6}, {4, 6}},
+ {{0, 7}, {1, 7}, {2, 7}, {3, 7}, {4, 7}},
+ {{0, 0}, {1, 0}, {2, 0}, {3, 0}, {4, 0}},
+ {{0, 1}, {1, 1}, {2, 1}, {3, 1}, {4, 1}},
+ {{0, 2}, {1, 2}, {2, 2}, {3, 2}, {4, 2}},
+ {{0, 3}, {1, 3}, {2, 3}, {3, 3}, {4, 3}}
+ };
+// clang-format on
+# ifdef ENCODER_MAP_ENABLE
+ const uint8_t PROGMEM encoder_hand_swap_config[NUM_ENCODERS] = {3,2,1,0};
+# endif
+#endif
diff --git a/keyboards/splitkb/aurora/sweep/rev1/rules.mk b/keyboards/splitkb/aurora/sweep/rev1/rules.mk
new file mode 100644
index 0000000000..c4275031ca
--- /dev/null
+++ b/keyboards/splitkb/aurora/sweep/rev1/rules.mk
@@ -0,0 +1,17 @@
+# Copyright 2022 splitkb.com <support@splitkb.com>
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+# Although no rules are defined,
+# presence of this file is required for QMK to compile it. \ No newline at end of file