summaryrefslogtreecommitdiffstats
path: root/keyboards/splitkb/aurora/lily58/keymaps
diff options
context:
space:
mode:
authorleah-splitkb <103112489+leah-splitkb@users.noreply.github.com>2022-12-06 16:57:50 +0100
committerGitHub <noreply@github.com>2022-12-06 15:57:50 +0000
commit0e93b0d59be24933d69756dae44fc02c979b466f (patch)
tree586f8812cf52193339a99eaa1f78f3dfe959adff /keyboards/splitkb/aurora/lily58/keymaps
parent2709b6ed616f8012ff4cfd3ee69a822a8d188351 (diff)
[Keyboard] Add splitkb.com's Aurora Lily58 (#19183)
Diffstat (limited to 'keyboards/splitkb/aurora/lily58/keymaps')
-rw-r--r--keyboards/splitkb/aurora/lily58/keymaps/debug/config.h21
-rw-r--r--keyboards/splitkb/aurora/lily58/keymaps/debug/keymap.c75
-rw-r--r--keyboards/splitkb/aurora/lily58/keymaps/debug/readme.md24
-rw-r--r--keyboards/splitkb/aurora/lily58/keymaps/debug/rules.mk23
-rw-r--r--keyboards/splitkb/aurora/lily58/keymaps/default/keymap.json52
-rw-r--r--keyboards/splitkb/aurora/lily58/keymaps/default/readme.md88
6 files changed, 283 insertions, 0 deletions
diff --git a/keyboards/splitkb/aurora/lily58/keymaps/debug/config.h b/keyboards/splitkb/aurora/lily58/keymaps/debug/config.h
new file mode 100644
index 0000000000..9e639dbc35
--- /dev/null
+++ b/keyboards/splitkb/aurora/lily58/keymaps/debug/config.h
@@ -0,0 +1,21 @@
+/* Copyright 2022 splitkb.com <support@splitkb.com>
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#pragma once
+
+#ifdef RGBLIGHT_ENABLE
+# define RGBLIGHT_EFFECT_BREATHING
+#endif
diff --git a/keyboards/splitkb/aurora/lily58/keymaps/debug/keymap.c b/keyboards/splitkb/aurora/lily58/keymaps/debug/keymap.c
new file mode 100644
index 0000000000..0bd2fa9370
--- /dev/null
+++ b/keyboards/splitkb/aurora/lily58/keymaps/debug/keymap.c
@@ -0,0 +1,75 @@
+/* Copyright 2022 splitkb.com <support@splitkb.com>
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#include QMK_KEYBOARD_H
+
+enum layers {
+ _DEFAULT = 0,
+};
+
+const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
+ [_DEFAULT] = LAYOUT(
+ KC_A, KC_B, KC_C, KC_D, KC_E, KC_F, S(KC_F), S(KC_E), S(KC_D), S(KC_C), S(KC_B), S(KC_A),
+ KC_G, KC_H, KC_I, KC_J, KC_K, KC_L, S(KC_L), S(KC_K), S(KC_J), S(KC_I), S(KC_H), S(KC_G),
+ KC_M, KC_N, KC_O, KC_P, KC_Q, KC_R, S(KC_R), S(KC_Q), S(KC_P), S(KC_O), S(KC_N), S(KC_M),
+ KC_S, KC_T, KC_U, KC_V, KC_W, KC_X, KC_Y, S(KC_Y), S(KC_X), S(KC_W), S(KC_V), S(KC_U), S(KC_T), S(KC_S),
+ KC_Z, KC_1, KC_2, KC_3, S(KC_3), S(KC_2), S(KC_1), S(KC_Z)
+
+ )
+};
+
+#ifdef RGBLIGHT_ENABLE
+void keyboard_post_init_user(void) {
+ rgblight_enable_noeeprom(); // enables RGB, without saving settings
+ rgblight_sethsv_noeeprom(HSV_RED); // sets the color to red without saving
+ rgblight_mode_noeeprom(RGBLIGHT_MODE_BREATHING + 3); // sets mode to Fast breathing without saving
+}
+#endif
+
+#ifdef ENCODER_ENABLE
+bool encoder_update_user(uint8_t index, bool clockwise) {
+ // 0 is left-half encoder
+ // 1 is right-half encoder
+ if (index == 0) {
+ tap_code(KC_0);
+ } else if (index == 1) {
+ tap_code(KC_1);
+ }
+
+ if (clockwise) {
+ tap_code16(KC_PLUS);
+ } else {
+ tap_code(KC_MINUS);
+ }
+
+ return false;
+}
+#endif
+
+#ifdef OLED_ENABLE
+bool oled_task_user(void) {
+ // A 128x32 OLED rotated 90 degrees is 5 characters wide and 16 characters tall
+ // This example string should fill that neatly
+ const char *text = PSTR("abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ123456789!@#$%^&*()[]{}-=_+?");
+
+ if (is_keyboard_master()) {
+ oled_write_P(text, false);
+ } else {
+ oled_write_P(text, false);
+ }
+ return false;
+}
+#endif
diff --git a/keyboards/splitkb/aurora/lily58/keymaps/debug/readme.md b/keyboards/splitkb/aurora/lily58/keymaps/debug/readme.md
new file mode 100644
index 0000000000..8c51d64842
--- /dev/null
+++ b/keyboards/splitkb/aurora/lily58/keymaps/debug/readme.md
@@ -0,0 +1,24 @@
+# Aurora Lily58's Debug Keymap
+
+To make debugging your build as easy as possible, we have provided a special debugging keymap. It is not intended to actually type on, it is just here to make sure that your hardware is working correctly.
+
+## Keys
+
+![Keys](https://i.imgur.com/CF0PYu5h.png)
+
+The left side uses lowercase letters, the right side uses uppercase ones.
+
+## Encoders
+
+Encoders output a number of 0 or 1, depending on the installed position.
+These correspond to the index used for custom encoder code: the left half uses index 0, the right half uses index 1.
+
+The number is followed by either a `+` or a `-`, depending on the direction turned.
+
+## LEDs
+
+Both underglow and per-key RGB should be fading between red and off.
+
+## OLEDs
+
+Both the primary and secondary side should be filled with characters.
diff --git a/keyboards/splitkb/aurora/lily58/keymaps/debug/rules.mk b/keyboards/splitkb/aurora/lily58/keymaps/debug/rules.mk
new file mode 100644
index 0000000000..c8a3944323
--- /dev/null
+++ b/keyboards/splitkb/aurora/lily58/keymaps/debug/rules.mk
@@ -0,0 +1,23 @@
+# Copyright 2022 splitkb.com <support@splitkb.com>
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+# NOTE: These are already enabled by default at the revision level
+#ENCODER_ENABLE = yes
+#OLED_ENABLE = yes
+
+# RGB Matrix is enabled at the revision level,
+# while we use the regular RGB underglow for testing
+RGB_MATRIX_ENABLE = no
+RGBLIGHT_ENABLE = yes
diff --git a/keyboards/splitkb/aurora/lily58/keymaps/default/keymap.json b/keyboards/splitkb/aurora/lily58/keymaps/default/keymap.json
new file mode 100644
index 0000000000..ad203b5e68
--- /dev/null
+++ b/keyboards/splitkb/aurora/lily58/keymaps/default/keymap.json
@@ -0,0 +1,52 @@
+{
+ "keyboard": "splitkb/aurora/lily58",
+ "keymap": "default",
+ "version": 1,
+ "layout": "LAYOUT",
+ "layers": [
+ [
+ "KC_ESC" , "KC_1" , "KC_2" , "KC_3" , "KC_4" , "KC_5" , "KC_6" , "KC_7" , "KC_8" , "KC_9" , "KC_0" , "KC_GRV" ,
+ "KC_TAB" , "KC_Q" , "KC_W" , "KC_E" , "KC_R" , "KC_T" , "KC_Y" , "KC_U" , "KC_I" , "KC_O" , "KC_P" , "KC_MINS",
+ "KC_LCTL", "KC_A" , "KC_S" , "KC_D" , "KC_F" , "KC_G" , "KC_H" , "KC_J" , "KC_K" , "KC_L" , "KC_SCLN", "KC_QUOT",
+ "KC_LSFT", "KC_Z" , "KC_X" , "KC_C" , "KC_V" , "KC_B" , "KC_LBRC", "KC_RBRC", "KC_N" , "KC_M" , "KC_COMM", "KC_DOT" , "KC_SLSH", "KC_RSFT",
+ "KC_LALT", "KC_LGUI", "MO(1)" , "KC_SPC" , "KC_ENT" , "MO(2)" , "KC_BSPC", "KC_RGUI"
+ ],
+ [
+ "_______", "_______", "_______", "_______", "_______", "_______", "_______", "_______", "_______", "_______", "_______", "_______",
+ "KC_F1" , "KC_F2", "KC_F3", "KC_F4" , "KC_F5" , "KC_F6" , "KC_F7" , "KC_F8" ,"KC_F9" , "KC_F10" , "KC_F11" , "KC_F12" ,
+ "KC_GRV" , "KC_EXLM", "KC_AT" , "KC_HASH", "KC_DLR" , "KC_PERC", "KC_CIRC", "KC_AMPR", "KC_ASTR", "KC_LPRN", "KC_RPRN", "KC_TILD",
+ "_______", "_______", "_______", "_______", "_______", "_______", "_______", "_______", "XXXXXXX", "KC_UNDS", "KC_PLUS", "KC_LCBR", "KC_RCBR", "KC_PIPE",
+ "_______", "_______", "_______", "_______", "_______", "MO(3)" , "_______", "_______"
+ ],
+ [
+ "_______", "_______", "_______", "_______", "_______", "_______", "_______", "_______", "_______", "_______", "_______", "_______",
+ "KC_GRV" , "KC_1" , "KC_2" , "KC_3" , "KC_4" , "KC_5" , "KC_6" , "KC_7" , "KC_8" , "KC_9" , "KC_0" , "_______",
+ "KC_F1" , "KC_F2" , "KC_F3" , "KC_F4" , "KC_F5" , "KC_F6" , "XXXXXXX", "KC_LEFT", "KC_DOWN", "KC_UP" , "KC_RGHT", "XXXXXXX",
+ "KC_F7" , "KC_F8" , "KC_F9" , "KC_F10" , "KC_F11" , "KC_F12" , "_______", "_______", "KC_PLUS", "KC_MINS", "KC_EQL" , "KC_LBRC", "KC_RBRC", "KC_BSLS",
+ "_______", "_______", "MO(3)" , "_______", "_______", "_______", "_______", "_______"
+ ],
+ [
+ "XXXXXXX", "XXXXXXX", "XXXXXXX", "XXXXXXX", "XXXXXXX", "XXXXXXX", "XXXXXXX", "XXXXXXX", "XXXXXXX", "XXXXXXX", "XXXXXXX", "XXXXXXX",
+ "XXXXXXX", "XXXXXXX", "XXXXXXX", "XXXXXXX", "XXXXXXX", "XXXXXXX", "XXXXXXX", "XXXXXXX", "XXXXXXX", "XXXXXXX", "XXXXXXX", "XXXXXXX",
+ "XXXXXXX", "XXXXXXX", "XXXXXXX", "XXXXXXX", "XXXXXXX", "XXXXXXX", "XXXXXXX", "XXXXXXX", "RGB_TOG", "RGB_HUI", "RGB_SAI", "RGB_VAI",
+ "XXXXXXX", "XXXXXXX", "XXXXXXX", "XXXXXXX", "XXXXXXX", "XXXXXXX", "XXXXXXX", "XXXXXXX", "XXXXXXX", "XXXXXXX", "RGB_MOD", "RGB_HUD", "RGB_SAD", "RGB_VAD",
+ "_______", "_______", "_______", "_______", "_______", "_______", "_______", "_______"
+ ]
+ ],
+ "config": {
+ "features": {
+ "oled": true,
+ "rgb_matrix": true,
+ "rgblight": false
+ },
+ "encoder": {
+ "enabled": true
+ },
+ "rgblight": {
+ "hue_steps": 8,
+ "saturation_steps": 8,
+ "brightness_steps": 8,
+ "sleep": true
+ }
+ }
+}
diff --git a/keyboards/splitkb/aurora/lily58/keymaps/default/readme.md b/keyboards/splitkb/aurora/lily58/keymaps/default/readme.md
new file mode 100644
index 0000000000..05cf701699
--- /dev/null
+++ b/keyboards/splitkb/aurora/lily58/keymaps/default/readme.md
@@ -0,0 +1,88 @@
+# Aurora Lily58's Default Keymap
+_This keymap is a copy of the [Lily58 default keymap](https://github.com/qmk/qmk_firmware/tree/master/keyboards/lily58/keymaps/default), with slight modifications._
+
+A simple default keymap for the Aurora Lily58
+=============================================
+
+Keymaps in general are quite personal, so it is difficult to come up with a default that will suit every user. We hope this keymap serves as a good starting point for your own - although it should be fairly usable out-of-the-box.
+
+What do all these layers do?
+----------------------------
+
+### Layer 0: Base layer
+
+![Layer 0](https://i.imgur.com/sq8Rql7h.png)
+
+This is where your basic letters live.
+
+The homing thumb fingers are used to access the different layers.
+
+* The homing left thumb finger gives access to the Symbols (or lower) layer
+* The homing right thumb finger gives access to the Navigation (or raise) layer
+* Pressing both homing thumb fingers gives access to the Adjust layer
+
+### Layer 1: Lower
+
+![Layer 1](https://i.imgur.com/baSE2OJh.png)
+
+The Lower layer gives access to the F keys on the second row, and shifted number keys on the home row. It also provides some shifted symbol keys.
+
+### Layer 2: Raise
+
+![Layer 2](https://i.imgur.com/CRnDa6Nh.png)
+
+The Raise layer gives access the arrow keys on the right hand, in addition to some unshifted symbols. The left hand provides an alternative set of F keys, while the second row provides an alternative set of number keys.
+
+### Layer 3: Adjust
+
+![Layer 3](https://i.imgur.com/QbCiTcyh.png)
+
+The Adjust layer exposes RGB adjustment keys on the right hand.
+
+Where is the keymap.c?
+----------------------
+
+The keymap.c file is not published to the repository. It is generated from `keymap.json` by the build system.
+
+This avoids duplicating information and allow users to edit their keymap from the QMK Configurator web interface.
+
+How do I edit and update the keymap?
+------------------------------------
+
+The `keymap.json` file is generated from the QMK Configurator interface and formatted for better readability in the context of the Ferris keyboard.
+
+To edit it, you may:
+* Edit it directly from a text editor.
+* Edit it from the QMK Configurator.
+
+If you decide to use the latter workflow, here are the steps to follow:
+
+* From the [QMK Configurator](https://config.qmk.fm/#/splitkb/aurora/lily58/rev1/LAYOUT), hit the "import QMK keymap json file" button (it has a drawing with an up arrow on it).
+* Browse to the location of your keymap (for example, `<your qmk repo>/keyboards/splitkb/aurora/lily58/keymaps/default/keymap.json`)
+* Perform any modification to the keymap in the web UI
+* Export the keymap to your downloads folder, by hitting the "Export QMK keymap json file" button (it has a drawing with a down arrow on it)
+* Replace your original keymap with the one you just downloaded
+
+_**Note:** At the time of writing (the 24th of October 2022), not every feature used in the default keymap is supported by the QMK Configurator. You cannot yet upload the default `keymap.json` due to a file format mismatch - use the "Load Default" button to load the default keymap instead. Additionally, custom configuration options are still being worked on: if your keymap depends on them, please compile your firmware offline for now._
+
+I want to do more than the JSON format supports!
+-------------------------------------------------
+
+While the `json` format is easy to use, it does lack certain functionality - most notably custom OLED or encoder behaviour.
+
+To add this, you need to convert it to the `c` format. Do keep in mind that this is generally a one-way operation.
+
+First, from the root of your qmk repo, move to your keymap folder
+
+```bash
+cd ./keymaps/splitkb/aurora/lily58/my_personal_keymap
+```
+
+Next, convert your `keymap.json` to a `keymap.c`
+
+```bash
+qmk json2c -o keymap.c keymap.json
+```
+
+You can add custom C code to the newly generated `keymap.c` file. Do note that you have to use **either** a C file **or** a JSON file - you cannot do both!
+**If a JSON file is present, the C file is ignored.** \ No newline at end of file