summaryrefslogtreecommitdiffstats
path: root/Reaktor/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Reaktor/default.nix')
-rw-r--r--Reaktor/default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/Reaktor/default.nix b/Reaktor/default.nix
new file mode 100644
index 00000000..96e3b120
--- /dev/null
+++ b/Reaktor/default.nix
@@ -0,0 +1,15 @@
+with import <nixpkgs> {};
+# nix-shell --pure .
+stdenv.mkDerivation rec {
+ name = "Reaktor-${version}";
+ version = "0.2.6";
+ buildInputs = with pkgs;[
+ python34
+ python34Packages.docopt
+ ];
+
+ shellHook =''
+ [ ! -d venv ] && virtualenv --python=python3.4 venv
+ . venv/bin/activate
+ '' ;
+}