summaryrefslogtreecommitdiffstats
path: root/pager.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pager.nix')
-rw-r--r--pager.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/pager.nix b/pager.nix
new file mode 100644
index 0000000..5f0de90
--- /dev/null
+++ b/pager.nix
@@ -0,0 +1,19 @@
+{ mkDerivation, aeson, base, blessings, bytestring, containers
+, data-default, hack, http-client, http-types, io-streams, network
+, optparse-applicative, probability, scanner, speculate, split
+, stdenv, template-haskell, terminal-size, text, time, unix
+}:
+mkDerivation {
+ pname = "pager";
+ version = "1.0.0";
+ src = ./.;
+ isLibrary = true;
+ isExecutable = true;
+ libraryHaskellDepends = [ aeson base template-haskell text ];
+ executableHaskellDepends = [
+ aeson base blessings bytestring containers data-default hack
+ http-client http-types io-streams network optparse-applicative
+ probability scanner speculate split terminal-size text time unix
+ ];
+ license = stdenv.lib.licenses.mit;
+}