aboutsummaryrefslogtreecommitdiffstats
path: root/pkgs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/default.nix')
-rw-r--r--pkgs/default.nix15
1 files changed, 0 insertions, 15 deletions
diff --git a/pkgs/default.nix b/pkgs/default.nix
index 8c62f1b..a236d1d 100644
--- a/pkgs/default.nix
+++ b/pkgs/default.nix
@@ -447,21 +447,6 @@ pkgs: oldpkgs: {
writePerlBin = name:
pkgs.writePerl "/bin/${name}";
- writePython2 = name: { deps ? [], flakeIgnore ? [] }:
- let
- py = pkgs.python2.withPackages (ps: deps);
- ignoreAttribute = optionalString (flakeIgnore != []) "--ignore ${concatMapStringsSep "," escapeShellArg flakeIgnore}";
- in
- pkgs.makeScriptWriter {
- interpreter = "${py}/bin/python";
- check = pkgs.writeDash "python2check.sh" ''
- exec ${pkgs.python2Packages.flake8}/bin/flake8 --show-source ${ignoreAttribute} "$1"
- '';
- } name;
-
- writePython2Bin = name:
- pkgs.writePython2 "/bin/${name}";
-
writePython3 = name: { deps ? [], flakeIgnore ? [] }:
let
py = pkgs.python3.withPackages (ps: deps);