aboutsummaryrefslogtreecommitdiffstats
path: root/examples/hello_world.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2018-09-23 13:05:11 +0200
committerlassulus <lassulus@lassul.us>2018-09-23 13:07:06 +0200
commit337d8707baec290dd6d8bfb14511d8011baa48aa (patch)
treec02c87b236a2e62240d9944270f560d8ac094aba /examples/hello_world.nix
parentb36e2e0127d3f607e8e7c8840aea10d7aee32b7f (diff)
pkgs: add writeJS{,Bin}lass/js
Diffstat (limited to 'examples/hello_world.nix')
-rw-r--r--examples/hello_world.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/examples/hello_world.nix b/examples/hello_world.nix
index 4944c13..4f9330a 100644
--- a/examples/hello_world.nix
+++ b/examples/hello_world.nix
@@ -18,6 +18,9 @@ in {
main = do
putStrLn "hello world"
'';
+ js = pkgs.writeJS "hello-world" {} ''
+ console.log("hello world")
+ '';
perl = pkgs.writePerl "hello-world" {} ''
print "hello world\n";
'';