summaryrefslogtreecommitdiffstats
path: root/nix/email-header.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-01-11 21:53:13 +0100
committertv <tv@shackspace.de>2015-01-11 21:53:13 +0100
commit5273db3d5c21cd4ef331df57e09c58c93bcc3f46 (patch)
treedd62e266744497088f2749568b797793e5daf208 /nix/email-header.nix
parentdf057aa8493de81770576c596fe6a497605481ea (diff)
notmuch insert reply drafts
Diffstat (limited to 'nix/email-header.nix')
-rw-r--r--nix/email-header.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/nix/email-header.nix b/nix/email-header.nix
new file mode 100644
index 0000000..10e1c79
--- /dev/null
+++ b/nix/email-header.nix
@@ -0,0 +1,29 @@
+# This file was auto-generated by cabal2nix. Please do NOT edit manually!
+
+{ cabal, attoparsec, base64Bytestring, caseInsensitive, exceptions
+, fetchgit, QuickCheck, tasty, tastyQuickcheck, text, textIcu, time
+}:
+
+cabal.mkDerivation (self: {
+ pname = "email-header";
+ version = "0.3.0";
+ src = fetchgit {
+ url = "https://github.com/4z3/email-header";
+ sha256 = "f8e77302594d8ff163a5df75dd886f9932ef9d1a084f79c0393b48fcb2a51eb4";
+ rev = "3ba16e71cf1fff92fd86199f893d89a40ca1275d";
+ };
+ buildDepends = [
+ attoparsec base64Bytestring caseInsensitive exceptions text textIcu
+ time
+ ];
+ testDepends = [
+ caseInsensitive QuickCheck tasty tastyQuickcheck text time
+ ];
+ jailbreak = true;
+ meta = {
+ homepage = "http://github.com/knrafto/email-header";
+ description = "Parsing and rendering of email and MIME headers";
+ license = self.stdenv.lib.licenses.bsd3;
+ platforms = self.ghc.meta.platforms;
+ };
+})