summaryrefslogtreecommitdiffstats
path: root/nix/email-header.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-02-20 12:15:51 +0100
committertv <tv@shackspace.de>2015-02-20 12:15:51 +0100
commit42547dc1c81411c9ae6ffa62d00249060b48021b (patch)
tree2ca5018bfe3ce7d37ee041edcaaed8fcc81e08a2 /nix/email-header.nix
parentda7bf1ca587f66857b496f707bc3271cf366fcd3 (diff)
use haskell-ng
Diffstat (limited to 'nix/email-header.nix')
-rw-r--r--nix/email-header.nix28
1 files changed, 12 insertions, 16 deletions
diff --git a/nix/email-header.nix b/nix/email-header.nix
index 10e1c79..a6caea2 100644
--- a/nix/email-header.nix
+++ b/nix/email-header.nix
@@ -1,10 +1,8 @@
-# This file was auto-generated by cabal2nix. Please do NOT edit manually!
-
-{ cabal, attoparsec, base64Bytestring, caseInsensitive, exceptions
-, fetchgit, QuickCheck, tasty, tastyQuickcheck, text, textIcu, time
+{ mkDerivation, attoparsec, base, base64-bytestring, bytestring
+, case-insensitive, containers, exceptions, fetchgit, QuickCheck
+, stdenv, tasty, tasty-quickcheck, text, text-icu, time
}:
-
-cabal.mkDerivation (self: {
+mkDerivation {
pname = "email-header";
version = "0.3.0";
src = fetchgit {
@@ -13,17 +11,15 @@ cabal.mkDerivation (self: {
rev = "3ba16e71cf1fff92fd86199f893d89a40ca1275d";
};
buildDepends = [
- attoparsec base64Bytestring caseInsensitive exceptions text textIcu
- time
+ attoparsec base base64-bytestring bytestring case-insensitive
+ containers exceptions text text-icu time
];
testDepends = [
- caseInsensitive QuickCheck tasty tastyQuickcheck text time
+ base bytestring case-insensitive containers QuickCheck tasty
+ tasty-quickcheck text time
];
jailbreak = true;
- meta = {
- homepage = "http://github.com/knrafto/email-header";
- description = "Parsing and rendering of email and MIME headers";
- license = self.stdenv.lib.licenses.bsd3;
- platforms = self.ghc.meta.platforms;
- };
-})
+ homepage = "http://github.com/knrafto/email-header";
+ description = "Parsing and rendering of email and MIME headers";
+ license = stdenv.lib.licenses.bsd3;
+}