summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2019-12-29 15:51:29 +0100
committertv <tv@krebsco.de>2019-12-29 16:29:43 +0100
commit9585885012dd6cd43516b81a85b6b25ae2b044ab (patch)
tree24f7ec7c2e839d009990e446c8dcd5fdb88a6567 /tests/Makefile.am
parent8ec8e8a051c57230443e97279b274fcb620e9540 (diff)
[WIP] prometheus module fake_stats testprometheus
Based on 51053ebb9ea7068b7a4e6bff11a470d4c4dedb37
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index bf7017b1..506edc5d 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -63,6 +63,7 @@ endif
if !EMBEDDED
check_PROGRAMS += \
stats/stats_test \
+ stats/fake_stats \
exec/exec_test
endif
@@ -76,6 +77,9 @@ utils_utils_test_LDADD = $(LDADD) $(top_builddir)/src/gsm/libosmogsm.la
stats_stats_test_SOURCES = stats/stats_test.c
stats_stats_test_LDADD = $(LDADD) $(top_builddir)/src/gsm/libosmogsm.la
+stats_fake_stats_SOURCES = stats/fake_stats.c
+stats_fake_stats_LDADD = $(LDADD) $(top_builddir)/src/vty/libosmovty.la
+
a5_a5_test_SOURCES = a5/a5_test.c
a5_a5_test_LDADD = $(LDADD) $(top_builddir)/src/gsm/libgsmint.la