aboutsummaryrefslogtreecommitdiffstats
path: root/pkgs/krops/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/krops/default.nix')
-rw-r--r--pkgs/krops/default.nix62
1 files changed, 27 insertions, 35 deletions
diff --git a/pkgs/krops/default.nix b/pkgs/krops/default.nix
index 8336b51..7fe8370 100644
--- a/pkgs/krops/default.nix
+++ b/pkgs/krops/default.nix
@@ -4,20 +4,14 @@ in
{ nix, openssh, populate, writers }: rec {
- build = target:
- runShell target (lib.concatStringsSep " " [
- "nix build"
- "-I ${lib.escapeShellArg target.path}"
- "--no-link -f '<nixpkgs/nixos>'"
- "config.system.build.toplevel"
- ]);
-
rebuild = args: target:
- runShell target "nixos-rebuild -I ${lib.escapeShellArg target.path} ${
+ runShell target {} "nixos-rebuild -I ${lib.escapeShellArg target.path} ${
lib.concatMapStringsSep " " lib.escapeShellArg args
}";
- runShell = target: command:
+ runShell = target: {
+ allocateTTY ? false
+ }: command:
let
command' = if target.sudo then "sudo ${command}" else command;
in
@@ -26,9 +20,8 @@ in
else
writers.writeDash "krops.${target.host}.${lib.firstWord command}" ''
exec ${openssh}/bin/ssh ${lib.escapeShellArgs (lib.flatten [
- (lib.optionals (target.user != "") ["-l" target.user])
- "-p" target.port
- "-T"
+ (lib.mkUserPortSSHOpts target)
+ (if allocateTTY then "-t" else "-T")
target.extraOptions
target.host
command'])}
@@ -38,6 +31,7 @@ in
command ? (targetPath: "echo ${targetPath}"),
backup ? false,
force ? false,
+ allocateTTY ? false,
source,
target
}: let
@@ -46,14 +40,14 @@ in
writers.writeDash name ''
set -efu
${populate { inherit backup force source; target = target'; }}
- ${runShell target' (command target'.path)}
+ ${runShell target' { inherit allocateTTY; } (command target'.path)}
'';
writeDeploy = name: {
backup ? false,
buildTarget ? null,
crossDeploy ? false,
- fast ? false,
+ fast ? null,
force ? false,
source,
target
@@ -64,26 +58,24 @@ in
else lib.mkTarget buildTarget;
target' = lib.mkTarget target;
in
- writers.writeDash name ''
- set -efu
- ${lib.optionalString (buildTarget' != target')
- (populate { inherit backup force source; target = buildTarget'; })}
- ${populate { inherit backup force source; target = target'; }}
- ${lib.optionalString (! fast) ''
- ${rebuild ["dry-build"] buildTarget'}
- ${build buildTarget'}
- ''}
- ${rebuild ([
- "switch"
- ] ++ lib.optionals crossDeploy [
- "--no-build-nix"
- ] ++ lib.optionals (buildTarget' != target') [
- "--build-host" "${buildTarget'.user}@${buildTarget'.host}"
- "--target-host" "${target'.user}@${target'.host}"
- ] ++ lib.optionals target'.sudo [
- "--use-remote-sudo"
- ]) buildTarget'}
- '';
+ lib.traceIf (fast != null) "writeDeploy: it's now always fast, setting the `fast` attribute is deprecated and will be removed in future" (
+ writers.writeDash name ''
+ set -efu
+ ${lib.optionalString (buildTarget' != target')
+ (populate { inherit backup force source; target = buildTarget'; })}
+ ${populate { inherit backup force source; target = target'; }}
+ ${rebuild ([
+ "switch"
+ ] ++ lib.optionals crossDeploy [
+ "--no-build-nix"
+ ] ++ lib.optionals (buildTarget' != target') [
+ "--build-host" "${buildTarget'.user}@${buildTarget'.host}"
+ "--target-host" "${target'.user}@${target'.host}"
+ ] ++ lib.optionals target'.sudo [
+ "--use-remote-sudo"
+ ]) buildTarget'}
+ ''
+ );
writeTest = name: {
backup ? false,