aboutsummaryrefslogtreecommitdiffstats
path: root/lib/types/populate.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/types/populate.nix')
-rw-r--r--lib/types/populate.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/lib/types/populate.nix b/lib/types/populate.nix
index bf90ace..e23ddb0 100644
--- a/lib/types/populate.nix
+++ b/lib/types/populate.nix
@@ -71,6 +71,11 @@
default = false;
type = lib.types.bool;
};
+ exclude = lib.mkOption {
+ type = lib.types.listOf lib.types.str;
+ default = [];
+ example = [".git"];
+ };
};
};
git = lib.types.submodule {