aboutsummaryrefslogtreecommitdiffstats
path: root/lib/types/populate.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/types/populate.nix')
-rw-r--r--lib/types/populate.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/lib/types/populate.nix b/lib/types/populate.nix
index 0427dbd..4ac9b1f 100644
--- a/lib/types/populate.nix
+++ b/lib/types/populate.nix
@@ -84,6 +84,16 @@
type = lib.types.bool;
};
exclude = lib.mkOption {
+ apply = x:
+ if x != [] then
+ lib.warn
+ "file.*.exclude is deprecated in favor of file.*.filters"
+ x
+ else
+ x;
+ description = ''
+ DEPRECATED, use `filters`.
+ '';
type = lib.types.listOf lib.types.str;
default = [];
example = [".git"];