aboutsummaryrefslogtreecommitdiffstats
path: root/lib/types/populate.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2020-03-17 19:32:46 +0100
committertv <tv@krebsco.de>2020-03-17 19:32:46 +0100
commit9c16ab1ce11eb2c16af97e1b293961178a9f1b7b (patch)
tree2fad32efa2be5d7605103a263c676b3ceb261bd5 /lib/types/populate.nix
parented9fc6658226b1525bc008205d76276f0054c6c5 (diff)
populate file: deprecated exclude option
Diffstat (limited to 'lib/types/populate.nix')
-rw-r--r--lib/types/populate.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/lib/types/populate.nix b/lib/types/populate.nix
index 0427dbd..4ac9b1f 100644
--- a/lib/types/populate.nix
+++ b/lib/types/populate.nix
@@ -84,6 +84,16 @@
type = lib.types.bool;
};
exclude = lib.mkOption {
+ apply = x:
+ if x != [] then
+ lib.warn
+ "file.*.exclude is deprecated in favor of file.*.filters"
+ x
+ else
+ x;
+ description = ''
+ DEPRECATED, use `filters`.
+ '';
type = lib.types.listOf lib.types.str;
default = [];
example = [".git"];