aboutsummaryrefslogtreecommitdiffstats
path: root/lib/types/populate.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/types/populate.nix')
-rw-r--r--lib/types/populate.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/lib/types/populate.nix b/lib/types/populate.nix
index 4ac9b1f..894b8cc 100644
--- a/lib/types/populate.nix
+++ b/lib/types/populate.nix
@@ -140,6 +140,10 @@
url = lib.mkOption {
type = lib.types.str; # TODO lib.types.git.url
};
+ shallow = lib.mkOption {
+ default = false;
+ type = lib.types.bool;
+ };
};
};
pass = lib.types.submodule {