aboutsummaryrefslogtreecommitdiffstats
path: root/lib/types/populate.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2020-07-02 19:44:56 +0200
committerGitHub <noreply@github.com>2020-07-02 19:44:56 +0200
commit5ea125514e48c630120fbb6a44e9ae0c7932a123 (patch)
tree6da01501ec47bade5a259d00c10f6f5a1c9c8c22 /lib/types/populate.nix
parent3e731035ed44659624e6d00bbb35570f2b8811fd (diff)
parent54eb1c89cf66ab882427c0d714f5c9a498687326 (diff)
Merge pull request #21 from elohmeier/git-shallowv1.23.0
add shallow option to git source type
Diffstat (limited to 'lib/types/populate.nix')
-rw-r--r--lib/types/populate.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/lib/types/populate.nix b/lib/types/populate.nix
index 4ac9b1f..894b8cc 100644
--- a/lib/types/populate.nix
+++ b/lib/types/populate.nix
@@ -140,6 +140,10 @@
url = lib.mkOption {
type = lib.types.str; # TODO lib.types.git.url
};
+ shallow = lib.mkOption {
+ default = false;
+ type = lib.types.bool;
+ };
};
};
pass = lib.types.submodule {