summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..1e27f23
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,34 @@
+
+let
+ pname = "news";
+ version = "1";
+
+ pkgs = nixpkgs // extrapkgs;
+ nixpkgs = import <nixpkgs> {};
+ extrapkgs = {
+ };
+ hsPkgs = pkgs.haskellPackages;
+ hsEnv = hsPkgs.ghcWithPackages (_hsPkgs: with _hsPkgs;
+ [
+ irc
+ irc-client
+ feed
+ split
+ warp
+ wai-util
+ ]);
+in
+
+pkgs.myEnvFun {
+ name = "${pname}-${version}";
+
+ buildInputs = with pkgs; [
+ hsEnv
+ ];
+
+ extraCmds = with pkgs; ''
+ $(grep export ${hsEnv.outPath}/bin/ghc)
+ '';
+}
+
+# vim: set fdm=marker :