summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-05-02 21:51:07 +0200
committertv <tv@krebsco.de>2017-05-02 21:51:14 +0200
commit6312ce9800708eaf619ad0e93af3a224e09ce4de (patch)
treec6389d1b06b56ee5d2b62a659f904e472f655406 /shell.nix
parentde13fa04339b8085d6b7bbdc1dd3ec31ec981701 (diff)
replace shell.nix by skeleton from much[1]
[1]: http://cgit.krebsco.de/much
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix34
1 files changed, 0 insertions, 34 deletions
diff --git a/shell.nix b/shell.nix
deleted file mode 100644
index 1e27f23..0000000
--- a/shell.nix
+++ /dev/null
@@ -1,34 +0,0 @@
-
-let
- pname = "news";
- version = "1";
-
- pkgs = nixpkgs // extrapkgs;
- nixpkgs = import <nixpkgs> {};
- extrapkgs = {
- };
- hsPkgs = pkgs.haskellPackages;
- hsEnv = hsPkgs.ghcWithPackages (_hsPkgs: with _hsPkgs;
- [
- irc
- irc-client
- feed
- split
- warp
- wai-util
- ]);
-in
-
-pkgs.myEnvFun {
- name = "${pname}-${version}";
-
- buildInputs = with pkgs; [
- hsEnv
- ];
-
- extraCmds = with pkgs; ''
- $(grep export ${hsEnv.outPath}/bin/ghc)
- '';
-}
-
-# vim: set fdm=marker :