summaryrefslogtreecommitdiffstats
path: root/pkgs/simple/hc.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/simple/hc.nix')
-rw-r--r--pkgs/simple/hc.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/pkgs/simple/hc.nix b/pkgs/simple/hc.nix
new file mode 100644
index 0000000..086445e
--- /dev/null
+++ b/pkgs/simple/hc.nix
@@ -0,0 +1,39 @@
+{ fetchgit, lib, makeWrapper, stdenv
+, coreutils, findutils, gawk, gnugrep, qrencode, texlive, utillinux, zbar
+}:
+
+stdenv.mkDerivation rec {
+ name = "hc-${meta.version}";
+
+ src = fetchgit {
+ url = "https://cgit.krebsco.de/hc";
+ rev = "refs/tags/v${meta.version}";
+ sha256 = "09349gja22p0j3xs082kp0fnaaada14bafszn4r3q7rg1id2slfb";
+ };
+
+ nativeBuildInputs = [ makeWrapper ];
+
+ buildPhase = null;
+
+ installPhase = ''
+ mkdir -p $out/bin
+
+ cp $src/bin/hc $out/bin/hc
+
+ wrapProgram $out/bin/hc \
+ --prefix PATH : ${lib.makeBinPath [
+ coreutils
+ findutils
+ gawk
+ gnugrep
+ qrencode
+ texlive.combined.scheme-full
+ utillinux
+ zbar
+ ]}
+ '';
+
+ meta = {
+ version = "1.0.0";
+ };
+}