summaryrefslogtreecommitdiffstats
path: root/modules/hw.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/hw.nix')
-rw-r--r--modules/hw.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/modules/hw.nix b/modules/hw.nix
new file mode 100644
index 0000000..653b04f
--- /dev/null
+++ b/modules/hw.nix
@@ -0,0 +1,15 @@
+{ lib, mylib, ... }: let
+ local.types.screen = lib.types.submodule {
+ options.width = lib.mkOption {
+ type = mylib.types.uint;
+ };
+ options.height = lib.mkOption {
+ type = mylib.types.uint;
+ };
+ };
+in {
+ options.tv.hw.screens = lib.mkOption {
+ type = lib.types.attrsOf local.types.screen;
+ default = {};
+ };
+}