summaryrefslogtreecommitdiffstats
path: root/configs/vim.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configs/vim.nix')
-rw-r--r--configs/vim.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/configs/vim.nix b/configs/vim.nix
index 757d702..cfe30eb 100644
--- a/configs/vim.nix
+++ b/configs/vim.nix
@@ -113,7 +113,13 @@
filetype plugin indent on
+ # [cursor] keep in sync with <hrm/configs/bash.nix>
+ &t_SI = "\e[6 q"
+ &t_EI = "\e[2 q"
+ au VimEnter * silent !echo -ne "\e[2 q"
+
set t_Co=256
+
colorscheme hack
au Syntax * syn match Garbage containedin=ALL /\s\+$/