summaryrefslogtreecommitdiffstats
path: root/configs/hw/AO753.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configs/hw/AO753.nix')
-rw-r--r--configs/hw/AO753.nix47
1 files changed, 47 insertions, 0 deletions
diff --git a/configs/hw/AO753.nix b/configs/hw/AO753.nix
new file mode 100644
index 0000000..ea58c01
--- /dev/null
+++ b/configs/hw/AO753.nix
@@ -0,0 +1,47 @@
+{ config, ... }: {
+ imports = [
+ ../smartd.nix
+
+ {
+ nix.settings.cores = 2;
+ nix.settings.max-jobs = 2;
+ }
+ (if lib.versionAtLeast (lib.versions.majorMinor lib.version) "21.11" then {
+ nix.daemonCPUSchedPolicy = "batch";
+ nix.daemonIOSchedPriority = 1;
+ } else {
+ nix.daemonIONiceLevel = 1;
+ nix.daemonNiceLevel = 1;
+ })
+ ];
+
+ boot.loader.grub = {
+ device = "/dev/sda";
+ splashImage = null;
+ };
+
+ boot.initrd.availableKernelModules = [
+ "ahci"
+ ];
+
+ boot.kernelModules = [
+ "kvm-intel"
+ "wl"
+ ];
+
+ boot.extraModulePackages = [
+ config.boot.kernelPackages.broadcom_sta
+ ];
+
+ services.logind.extraConfig = ''
+ HandleHibernateKey=ignore
+ HandleLidSwitch=ignore
+ HandlePowerKey=ignore
+ HandleSuspendKey=ignore
+ '';
+
+ krebs.nixpkgs.allowUnfreePredicate = pkg: packageName pkg == "broadcom-sta";
+
+ tv.hw.screens.primary.width = 1366;
+ tv.hw.screens.primary.height = 768;
+}